[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / chat / gajim-plugin-omemo

File: [cvs.NetBSD.org] / pkgsrc / chat / gajim-plugin-omemo / Makefile (download)

Revision 1.9, Fri Dec 4 20:45:01 2020 UTC (3 years, 2 months ago) by nia
Branch: MAIN
CVS Tags: pkgsrc-2021Q2-base, pkgsrc-2021Q2, pkgsrc-2021Q1-base, pkgsrc-2021Q1, pkgsrc-2020Q4-base, pkgsrc-2020Q4
Changes since 1.8: +2 -1 lines

Revbump packages with a runtime Python dep but no version prefix.

For the Python 3.8 default switch.

# $NetBSD: Makefile,v 1.9 2020/12/04 20:45:01 nia Exp $

PKGNAME=	gajim-plugin-omemo-2.6.28
PKGREVISION=	1
DISTNAME=	omemo_${PKGVERSION_NOREV}
CATEGORIES=	chat security python
MASTER_SITES=	https://ftp.gajim.org/plugins_releases/
EXTRACT_SUFX=	.zip

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	https://dev.gajim.org/gajim/gajim-plugins/wikis/OmemoGajimPlugin
COMMENT=	OMEMO encryption support for Gajim
LICENSE=	gnu-gpl-v3

DEPENDS+=	gajim-[0-9]*:../../chat/gajim
DEPENDS+=	${PYPKGPREFIX}-axolotl-[0-9]*:../../chat/py-axolotl
DEPENDS+=	${PYPKGPREFIX}-qrcode-[0-9]*:../../graphics/py-qrcode

PYTHON_VERSIONS_INCOMPATIBLE=	27

WRKSRC=		${WRKDIR}/omemo
USE_LANGUAGES=	# none
NO_BUILD=	yes
PY_PATCHPLIST=	yes

INSTALLATION_DIRS+=	${PYSITELIB}/gajim/data/plugins/omemo
INSTALLATION_DIRS+=	${PYSITELIB}/gajim/data/plugins/omemo/gtk
INSTALLATION_DIRS+=	${PYSITELIB}/gajim/data/plugins/omemo/omemo

do-install:
	${INSTALL_DATA} ${WRKSRC}/*.py ${WRKSRC}/*.png ${WRKSRC}/*.ini \
	    ${DESTDIR}${PREFIX}/${PYSITELIB}/gajim/data/plugins/omemo
	${INSTALL_DATA} ${WRKSRC}/gtk/*.ui ${WRKSRC}/gtk/*.css ${WRKSRC}/gtk/*.py \
	    ${DESTDIR}${PREFIX}/${PYSITELIB}/gajim/data/plugins/omemo/gtk
	${INSTALL_DATA} ${WRKSRC}/omemo/* \
	    ${DESTDIR}${PREFIX}/${PYSITELIB}/gajim/data/plugins/omemo/omemo

.include "../../lang/python/extension.mk"
.include "../../mk/bsd.pkg.mk"