[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / chat / empathy

Annotation of pkgsrc/chat/empathy/Makefile, Revision 1.6

1.6     ! wiz         1: # $NetBSD: Makefile,v 1.5 2009/03/22 19:01:37 wiz Exp $
1.1       wiz         2:
                      3: DISTNAME=      empathy-2.24.1
1.5       wiz         4: PKGREVISION=   1
1.1       wiz         5: CATEGORIES=    chat gnome
                      6: MASTER_SITES=  ${MASTER_SITE_GNOME:=sources/empathy/2.24/}
                      7:
                      8: MAINTAINER=    pkgsrc-users@NetBSD.org
                      9: HOMEPAGE=      http://live.gnome.org/Empathy
                     10: COMMENT=       Gnome instant messenger client
                     11:
                     12: # not strictly needed, but without any plugins, empathy is useless
                     13: DEPENDS+=      telepathy-gabble-[0-9]*:../../chat/telepathy-gabble
                     14: DEPENDS+=      telepathy-idle-[0-9]*:../../chat/telepathy-idle
                     15:
                     16: GNU_CONFIGURE=         yes
                     17: USE_TOOLS+=            gawk gmake intltool msgfmt pkg-config
1.3       jmcneill   18: USE_TOOLS+=            autoconf
1.1       wiz        19: USE_LIBTOOL=           yes
                     20: USE_PKGLOCALEDIR=      yes
                     21:
                     22: GCONF_SCHEMAS+=        GNOME_Megaphone_Applet.schemas
                     23: GCONF_SCHEMAS+=        empathy.schemas
                     24:
1.3       jmcneill   25: pre-configure:
                     26:        cd ${WRKSRC} && autoconf -f
                     27:
1.1       wiz        28: .include "../../chat/telepathy-mission-control/buildlink3.mk"
                     29: .include "../../chat/telepathy-glib/buildlink3.mk"
                     30: .include "../../devel/GConf/schemas.mk"
                     31: .include "../../devel/libglade/buildlink3.mk"
                     32: BUILDLINK_API_DEPENDS.glib2+=          glib2>=2.16.0
                     33: .include "../../devel/glib2/buildlink3.mk"
                     34: .include "../../graphics/hicolor-icon-theme/buildlink3.mk"
                     35: .include "../../lang/python/application.mk"
                     36: BUILDLINK_API_DEPENDS.enchant+=                enchant>=1.2.0
                     37: .include "../../mail/evolution-data-server/buildlink3.mk"
                     38: .include "../../sysutils/dbus/buildlink3.mk"
                     39: .include "../../sysutils/desktop-file-utils/desktopdb.mk"
                     40: .include "../../textproc/enchant/buildlink3.mk"
                     41: .include "../../textproc/gnome-doc-utils/buildlink3.mk"
                     42: .include "../../textproc/gtk-doc/buildlink3.mk"
                     43: .include "../../textproc/iso-codes/buildlink3.mk"
                     44: .include "../../textproc/libxslt/buildlink3.mk"
                     45: .include "../../textproc/libxml2/buildlink3.mk"
                     46: .include "../../x11/gnome-panel/buildlink3.mk"
                     47: BUILDLINK_API_DEPENDS.gtk2+=           gtk2+>=2.12.0
                     48: .include "../../x11/gtk2/buildlink3.mk"
                     49: .include "../../x11/libX11/buildlink3.mk"
                     50: .include "../../mk/omf-scrollkeeper.mk"
                     51: .include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>