File:  [cvs.NetBSD.org] / pkgsrc / chat / centerim / Makefile
Revision 1.36: download - view: text, annotated - select for diffs
Thu Jan 19 18:52:03 2017 UTC (8 years, 2 months ago) by agc
Branches: MAIN
CVS tags: pkgsrc-2017Q1-base, pkgsrc-2017Q1, HEAD
Convert all occurrences (353 by my count) of

	MASTER_SITES= 	site1 \
			site2

style continuation lines to be simple repeated

	MASTER_SITES+= site1
	MASTER_SITES+= site2

lines. As previewed on tech-pkg. With thanks to rillig for fixing pkglint
accordingly.

# $NetBSD: Makefile,v 1.36 2017/01/19 18:52:03 agc Exp $
#

DISTNAME=	centerim-4.22.10
PKGREVISION=	7
CATEGORIES=	chat
MASTER_SITES=	http://www.centerim.org/download/releases/
MASTER_SITES+=	http://transacid.de/centerim/releases/

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	http://www.centerim.org/
COMMENT=	Instant Messenger interface supporting many protocols
LICENSE=	gnu-gpl-v2

USE_PKGLOCALEDIR=	yes
USE_TOOLS+=		gmake perl:run
USE_LANGUAGES=		c c++

GNU_CONFIGURE=		yes
CONFIGURE_ARGS+=	--with-ssl --with-openssl=${SSLBASE:Q}
LIBS+=			${LDFLAGS}

REPLACE_PERL=		misc/cimextracthistory.pl
REPLACE_PERL+=		misc/cimconv
REPLACE_PYTHON+=	misc/CenterIMLog2HTML.py
REPLACE_AWK+=		misc/cimformathistory

INCOMPAT_CURSES+=	NetBSD-[0-5].*-* # see PR 29060

.include "options.mk"
.include "../../mk/bsd.prefs.mk"

.if ${OPSYS} == "NetBSD"
CPPFLAGS+=		-DAUDIO_PLAYER="\"/usr/bin/audioplay\""
.else
DEPENDS+=		sox>=12.17.4:../../audio/sox
CPPFLAGS+=		-DAUDIO_PLAYER="\"${LOCALBASE}/bin/play\""
.endif

.if !empty(MACHINE_ARCH:Msparc64)
GCC_REQD+=		3.0	# see PR 29185
.endif

.include "../../lang/python/application.mk"
.include "../../converters/libiconv/buildlink3.mk"
.include "../../devel/gettext-lib/buildlink3.mk"
.include "../../devel/ncurses/buildlink3.mk"
.include "../../security/openssl/buildlink3.mk"
.include "../../www/curl/buildlink3.mk"
.include "../../mk/jpeg.buildlink3.mk"

.if defined(BUILDLINK_LIBICONV_LDADD) && !empty(BUILDLINK_LIBICONV_LDADD)
#
# libiconv depends on configure scripts to include <iconv.h> before
# trying to link against -liconv.  Unfortunately, centericq's script
# doesn't do this, so fake it.
#
CONFIGURE_ENV+=		ac_cv_lib_iconv_iconv=yes
.endif

post-install:
	${INSTALL_MAN} ${WRKSRC}/centerim.1 ${DESTDIR}${PREFIX}/${PKGMANDIR}/man1/

.include "../../mk/bsd.pkg.mk"

.if ${MACHINE_ARCH} == "alpha"
# avoid toolchain bugs
CFLAGS:=	${CFLAGS:C/-O[0-9]*//g}
.endif

CVSweb <webmaster@jp.NetBSD.org>