[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / cad / qcad

Annotation of pkgsrc/cad/qcad/Makefile, Revision 1.75

1.75    ! nia         1: # $NetBSD: Makefile,v 1.74 2019/07/31 19:30:20 plunky Exp $
1.39      chap        2: #
1.1       jtb         3:
1.74      plunky      4: DISTNAME=              qcad-3.23.0.0
1.75    ! nia         5: PKGREVISION=           1
1.62      plunky      6: CATEGORIES=            cad
                      7: MASTER_SITES=          ${MASTER_SITE_GITHUB:=qcad/}
1.74      plunky      8: EXTRACT_USING=         bsdtar
1.39      chap        9:
1.62      plunky     10: MAINTAINER=            pkgsrc-users@NetBSD.org
                     11: HOMEPAGE=              http://www.qcad.org/
1.39      chap       12: COMMENT=               2D CAD system
1.62      plunky     13: LICENSE=               gnu-gpl-v3
1.39      chap       14:
1.62      plunky     15: GITHUB_TAG=            v${PKGVERSION_NOREV}
1.39      chap       16:
1.62      plunky     17: DEPENDS+=              bash-[0-9]*:../../shells/bash
1.39      chap       18:
1.62      plunky     19: USE_TOOLS+=            chmod find make pax
                     20: USE_LANGUAGES=         c c++
                     21: USE_LIBTOOL=           yes
1.39      chap       22:
1.41      rillig     23: SUBST_CLASSES+=                paths
1.71      jperkin    24: SUBST_STAGE.paths=     pre-configure
1.39      chap       25: SUBST_MESSAGE.paths=   Attending to hard-coded paths.
1.62      plunky     26: SUBST_FILES.paths+=    shared.pri src/core/RS.cpp src/core/RSettings.cpp
                     27: SUBST_FILES.paths+=    scripts/Help/ShowReadme/ShowReadme.js
                     28: SUBST_FILES.paths+=    scripts/Widgets/LibraryBrowser/LibraryBrowser.js
1.73      rillig     29: SUBST_VARS.paths=      PREFIX
1.39      chap       30:
1.62      plunky     31: AUTO_MKDIRS=   yes
1.1       jtb        32:
1.62      plunky     33: #
                     34: # The QCad build system normally links direct to a release dir but this
                     35: # causes a lot of problems with libtool dependencies. We patch it so that
                     36: # the libs are linked from the source dirs and add an install target to
                     37: # allow pkgsrc to use DESTDIR
                     38: #
                     39: # The Qt script bindings are built in Qt version specific subdirectory
                     40: # which we can't patch directly, so we create a fake qtscript.pro file
                     41: # and use it to overwrite Makefiles. Makefile.qtscript is ignored
                     42: #
                     43: do-configure:
                     44:        cd ${WRKSRC} && ${QTDIR}/bin/qmake -r -after DESTDIR=
                     45:        cd ${WRKSRC}/src/3rdparty && ${QTDIR}/bin/qmake -r -after DESTDIR= \
                     46:            INSTALLS+=target target.path=${PREFIX}/lib/${PKGBASE}/plugins/script \
                     47:            qtscript.pro -o Makefile.qtscript
1.47      joerg      48:
1.1       jtb        49: do-install:
1.62      plunky     50:        cd ${WRKSRC} && make INSTALL_ROOT=${DESTDIR} install
                     51:        ${INSTALL_DATA} ${WRKSRC}/qcad.desktop \
                     52:            ${DESTDIR}${PREFIX}/share/applications
                     53:        ${INSTALL_MAN} ${WRKSRC}/qcad.1 \
                     54:            ${DESTDIR}${PREFIX}/${PKGMANDIR}/man1
1.63      plunky     55:        ${FIND} ${WRKSRC}/scripts -name \*.orig -delete
1.62      plunky     56:        cd ${WRKSRC} && ${PAX} -rwpm fonts linetypes patterns \
                     57:            plugins scripts themes ts ${DESTDIR}${PREFIX}/lib/${PKGBASE}
                     58:        cd ${WRKSRC} && ${PAX} -rwpm readme.txt examples libraries \
                     59:            ${DESTDIR}${PREFIX}/share/${PKGBASE}
                     60:
                     61: .include "../../sysutils/desktop-file-utils/desktopdb.mk"
                     62: .include "../../devel/libexecinfo/buildlink3.mk"
1.68      plunky     63: .include "../../devel/zlib/buildlink3.mk"
1.75    ! nia        64: .include "../../x11/qt5-qtbase/buildlink3.mk"
        !            65: .include "../../x11/qt5-qtscript/buildlink3.mk"
        !            66: .include "../../x11/qt5-qtsvg/buildlink3.mk"
        !            67: .include "../../x11/qt5-qttools/buildlink3.mk"
        !            68: .include "../../x11/qt5-qtxmlpatterns/buildlink3.mk"
1.1       jtb        69: .include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>