File:  [cvs.NetBSD.org] / pkgsrc / cad / py-gdstk / Makefile
Revision 1.12: download - view: text, annotated - select for diffs
Fri Feb 23 09:39:17 2024 UTC (10 months, 3 weeks ago) by mef
Branches: MAIN
CVS tags: HEAD
(cad/py-gdstk) Updated 0.9.42 to 0.9.50

## 0.9.50 - 2024-02-07
### Added
- `Polygon.perimeter`.

## 0.9.49 - 2023-12-29
### Fixed
- Type annotation for `Cell.write_svg`.

## 0.9.48 - 2023-12-21
### Changed
- `Cell.dependencies` accepts keyword arguments.

### Fixed
- Fracturing polygons with few points is more robust.
- Compilation improvements.

## 0.9.45 - 2023-10-12
### Changed
- Use Qhull as an external dependecy instead of installing it
  ourselves to avoid conflicts.

## 0.9.43 - 2023-10-08
### Added
- `Library.remap` and `Cell.remap` to remap layer and data/text types
- Add typing stub
- Add deepcopy support

### Changed
- Raise an error if not both layer and datatype are specified in
  `Cell.get_polygons` and `Reference.get_polygons`.
- Correct ordering of path ends in `Library::read_oas()`

### Fixed
- Sort `Slice` Positions When converting from python because the
  internal implementation expects the coordinates to be sorted

# $NetBSD: Makefile,v 1.12 2024/02/23 09:39:17 mef Exp $

VERSION=	0.9.50
GITHUB_TAG=	v${VERSION}
DISTNAME=	gdstk-${VERSION}
PKGNAME=	${PYPKGPREFIX}-${DISTNAME}
CATEGORIES=	cad
MASTER_SITES=	${MASTER_SITE_GITHUB:=heitzmann/}
GITHUB_PROJECT=	gdstk

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	https://github.com/heitzmann/gdstk/
COMMENT=	C++ library for GDSII and OASIS files
LICENSE=	boost-license

WRKSRC=		${WRKDIR}/${DISTNAME}
USE_LANGUAGES+=	c c++
USE_TOOLS+=	cmake

PYTHON_VERSIONS_INCOMPATIBLE=	27 38

.include "../../devel/zlib/buildlink3.mk"
.include "../../math/py-numpy/buildlink3.mk"
.include "../../lang/python/wheel.mk"
.include "../../math/qhull/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>