Up to [cvs.NetBSD.org] / pkgsrc / cad / py-gdstk
Request diff between arbitrary revisions
Keyword substitution: kv
Default branch: MAIN
*: clean-up after python38 removal
py-gdstk: minor documentary improvements
py-gdstk: finish conversion to wheel.mk
(cad/py-gdstk) Updated 0.9.42 to 0.9.50 ## 0.9.50 - 2024-02-07 ### Added - `Polygon.perimeter`. ## 0.9.49 - 2023-12-29 ### Fixed - Type annotation for `Cell.write_svg`. ## 0.9.48 - 2023-12-21 ### Changed - `Cell.dependencies` accepts keyword arguments. ### Fixed - Fracturing polygons with few points is more robust. - Compilation improvements. ## 0.9.45 - 2023-10-12 ### Changed - Use Qhull as an external dependecy instead of installing it ourselves to avoid conflicts. ## 0.9.43 - 2023-10-08 ### Added - `Library.remap` and `Cell.remap` to remap layer and data/text types - Add typing stub - Add deepcopy support ### Changed - Raise an error if not both layer and datatype are specified in `Cell.get_polygons` and `Reference.get_polygons`. - Correct ordering of path ends in `Library::read_oas()` ### Fixed - Sort `Slice` Positions When converting from python because the internal implementation expects the coordinates to be sorted
*: remove more references to Python 3.7
*: restrict py-numpy users to 3.9+ in preparation for update
(cad/py-gdstk) Updated 0.9.41 to 0.9.42 ## 0.9.42 - 2023-06-14 ### Fixed - `racetrack` bug in inner radius
(cad/py-gdstk) Updated 0.9.40 to 0.9.41 ## 0.9.41 - 2023-05-24 ### Added - Dictionary-like access to library cells by name. - `len(Library)` returns the number of cells in the library - `Reference.cell_name` to directly access a referenced cell's name ### Fixed - `RobustPath` accepts width of 0 at the path end
(cad/py-gdstk) Updated 0.9.37 to 0.9.40, CHANGELOG.md not updated
(cad/py-gdstk) Updated 0.9.35 to 0.9.37 # Changelog ## 0.9.37 - 2023002-12 ### Changed - Build system changes for lower numpy version requirements ## 0.9.36 - 2023-02-10 ### Changed - Downgrade the zlib version dependency to support manylinux2014 - Minor documentation improvements
(cad/py-gdstk) Updated 0.9.34 to 0.9.35 # Changelog ## 0.9.35 - 2022-12-16 ### Fixed - Segfaults caused by class inheritance in Python - Segfaults caused by cleanup of incomplete initialization of Python instances
(cad/py-gdstk) Update 0.9.0 to 0.9.34 ## 0.9.33 - 2022-11-14 - build wheels for windows separately from macOs and linux ## 0.9.1 - 2022-10-12 ### Fixed - Reading polygons with extremelly large number of vertices - Integer overflow in boolean operations - `GdsWriter` C++ API fix - Properly read zlib path from environment during build - Ensure polygons are closed when laoding GDSII files - Reference counting in `Reference.apply_repetition` and `Cell.flatten`
(cad/gdstk) Updated 0.8.3 to 0.9.0 ## 0.9.0 2022-08-21 (Date from timestamp) ### Fixed - Bug when saving OASIS files with missing references. ### Added - `Reference.get_polygons`, `Reference.get_paths`, `Reference.get_labels` - `Library.rename_cell` - `Library::rename_cell` and `Library::replace_cell` in the C++ API ### Changed - `Cell.filter` arguments modified to match `read_gds`. - Changed default tolerance for `read_gds` and `read_oas` to be the library's rounding size. - `Reference::polygons` renamed to `Reference::get_polygons` in the C++ API. - `Reference::flexpaths` renamed to `Reference::get_flexpaths` in the C++ API. - `Reference::robustpaths` renamed to `Reference::get_robustpaths` in the C++ API. - `Reference::labels` renamed to `Reference::get_labels` in the C++ API. - Removed magnification argument from `Reference::init` and `Label::init` in the C++ API.
(cad/py-gdstk) Fix GITHUB_PROJECT (missing)
cad/py-gdstk: import py39-gdstk-0.8.3 Gdstk (GDSII Tool Kit) is a C++ library for creation and manipulation of GDSII and OASIS files. It is also available as a Python module meant to be a successor to Gdspy. Key features for the creation of complex CAD layouts are included: - Boolean operations on polygons (AND, OR, NOT, XOR) based on clipping algorithm - Polygon offset (inward and outward rescaling of polygons) - Efficient point-in-polygon solutions for large array sets Typical applications of Gdstk are in the fields of electronic chip design, planar lightwave circuit design, and mechanical engineering.