[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / cad / pcb

Annotation of pkgsrc/cad/pcb/Makefile, Revision 1.83

1.83    ! adam        1: # $NetBSD: Makefile,v 1.82 2016/04/11 04:22:33 dbj Exp $
1.27      dmcmahil    2: #
1.1       frueauf     3:
1.81      dmcmahil    4: DISTNAME=      pcb-20140316
1.83    ! adam        5: PKGREVISION=   1
1.1       frueauf     6: CATEGORIES=    cad
1.27      dmcmahil    7: MASTER_SITES=  ${MASTER_SITE_SOURCEFORGE:=pcb/}
1.1       frueauf     8:
1.21      grant       9: MAINTAINER=    dmcmahill@NetBSD.org
1.72      dmcmahil   10: HOMEPAGE=      http://pcb.geda-project.org/
1.27      dmcmahil   11: COMMENT=       Printed circuit board layout system
1.55      dmcmahil   12: LICENSE=       gnu-gpl-v2
1.1       frueauf    13:
1.42      dmcmahil   14: DEPENDS+=      gettext-tools>=0.14.6:../../devel/gettext-tools
                     15:
1.23      dmcmahil   16: CONFLICTS+=    pcb-current-[0-9]*
1.1       frueauf    17:
1.27      dmcmahil   18: GNU_CONFIGURE=         yes
1.30      jlam       19: CONFIGURE_ENV+=                WISH=${TOOLS_PATH.wish}
1.39      dmcmahil   20: # work around a problem where the configure script uses
1.41      martti     21: # AM_PROG_LEX and follows it with an AC_PATH_PROG to try
1.39      dmcmahil   22: # and make sure that lex really does exist.  Unfortunately
                     23: # that test is thrown off by pkgsrc giving a full path for LEX.
                     24: # so, bypass the test and put our desired result directly into the
                     25: # configure cache.  Same for YACC.
                     26: CONFIGURE_ENV+=                ac_cv_path_LEX_PATH=${TOOLS_PATH.lex}
                     27: CONFIGURE_ENV+=                ac_cv_path_YACC_PATH=${TOOLS_PATH.bison}
1.42      dmcmahil   28: CONFIGURE_ARGS+=       --disable-update-desktop-database
                     29: CONFIGURE_ARGS+=       --disable-update-mime-database
                     30: USE_TOOLS+=            bison gm4:run gmake intltool lex wish:run pkg-config
                     31: USE_PKGLOCALEDIR=      yes
1.37      dmcmahil   32: INFO_FILES=            yes
1.81      dmcmahil   33: LDFLAGS+=              -lstdc++  -lm # direct link as required by ld v2.22
1.7       dmcmahil   34:
1.57      dmcmahil   35: USE_LANGUAGES=         c c++
                     36:
1.35      dmcmahil   37: PKG_OPTIONS_VAR=               PKG_OPTIONS.pcb
                     38: PKG_SUPPORTED_OPTIONS=         png
                     39: PKG_OPTIONS_REQUIRED_GROUPS=   gui
1.38      dmcmahil   40: PKG_OPTIONS_GROUP.gui=         batch gtk motif
                     41: PKG_SUGGESTED_OPTIONS=         gtk png
1.15      jlam       42:
1.34      dmcmahil   43: .include "../../mk/bsd.prefs.mk"
                     44: .include "../../mk/bsd.options.mk"
                     45:
1.35      dmcmahil   46: .if !empty(PKG_OPTIONS:Mmotif)
1.34      dmcmahil   47: .include "../../mk/motif.buildlink3.mk"
                     48: CONFIGURE_ARGS+=       --with-gui=lesstif
1.38      dmcmahil   49: .elif !empty(PKG_OPTIONS:Mgtk)
1.57      dmcmahil   50: .include "../../graphics/gtkglext/buildlink3.mk"
                     51: .include "../../graphics/glu/buildlink3.mk"
1.27      dmcmahil   52: .include "../../x11/gtk2/buildlink3.mk"
1.34      dmcmahil   53: CONFIGURE_ARGS+=       --with-gui=gtk
1.38      dmcmahil   54: .elif !empty(PKG_OPTIONS:Mbatch)
                     55: CONFIGURE_ARGS+=       --with-gui=none
                     56: .else
1.82      dbj        57: PKG_FAIL_REASON+=      Invalid options
1.34      dmcmahil   58: .endif
                     59:
1.54      dmcmahil   60: # dbus is only needed if we are building a gui (lesstif/gtk)
                     61: .if empty(PKG_OPTIONS:Mbatch)
                     62: .include "../../sysutils/dbus/buildlink3.mk"
                     63: .endif
                     64:
1.81      dmcmahil   65: EXPORTERS=     bom gcode gerber ps
1.34      dmcmahil   66: .if !empty(PKG_OPTIONS:Mpng)
                     67: EXPORTERS+=    png
                     68: .include "../../graphics/gd/buildlink3.mk"
                     69: .endif
                     70:
                     71: CONFIGURE_ARGS+=       --with-exporters=${EXPORTERS:Q}
                     72:
1.45      hasso      73: post-extract:
                     74:        ${CHMOD} -R go-w ${WRKSRC}
                     75:
1.42      dmcmahil   76: # remove some stuff that is either broken or unmaintained
                     77: # and would require another runtime depends
                     78: post-install:
1.43      joerg      79:        ${RM} ${DESTDIR}${PREFIX}/share/pcb/tools/PCB2HPGL
                     80:        ${RM} ${DESTDIR}${PREFIX}/share/pcb/tools/tgo2pcb.tcl
1.42      dmcmahil   81:
1.57      dmcmahil   82: .include "../../devel/gettext-lib/buildlink3.mk"
1.47      dmcmahil   83: # NOTE:  glib is needed by the core of pcb and not just the GTK gui.
                     84: .include "../../devel/glib2/buildlink3.mk"
1.42      dmcmahil   85: .include "../../graphics/hicolor-icon-theme/buildlink3.mk"
                     86: .include "../../sysutils/desktop-file-utils/desktopdb.mk"
1.1       frueauf    87: .include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>