[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / cad / lc

Annotation of pkgsrc/cad/lc/Makefile, Revision 1.9

1.9     ! dmcmahil    1: # $NetBSD: Makefile,v 1.8 2007/02/24 03:32:07 dmcmahill Exp $
1.1       dmcmahil    2:
                      3: DISTNAME=      lc      # Overridden below
                      4: PKGNAME=       lc-2.10
1.7       dmcmahil    5: PKGREVISION=   2
1.1       dmcmahil    6: CATEGORIES=    cad
                      7: MASTER_SITES=  http://lc.cray.com/download/
                      8:
                      9: MAINTAINER=    dmcmahill@NetBSD.org
                     10: HOMEPAGE=      http://lc.cray.com/
                     11: COMMENT=       Finite Difference Time Domain (FDTD) Electromagnetic Simulator
                     12:
                     13: DIST_SUBDIR=   ${PKGNAME_NOREV}
                     14:
                     15: RESTRICTED=    Original installer required to redistribute.
                     16: NO_SRC_ON_CDROM=       ${RESTRICTED}
                     17: NO_BIN_ON_CDROM=       ${RESTRICTED}
                     18: NO_BIN_ON_FTP=         ${RESTRICTED}
                     19: NO_SRC_ON_FTP=         ${RESTRICTED}
                     20: LICENSE=               lc-license
                     21: CHECK_SHLIBS_SUPPORTED=        no
                     22:
                     23: WRKSRC=                ${WRKDIR}/lc2.10
                     24: NO_BUILD=      YES
                     25:
                     26: .include "../../mk/bsd.prefs.mk"
                     27:
                     28: # With this, we can run
                     29: #  make makesum MAINTAINER_MODE=yes
                     30: # and process all the possible distfiles without regard to what platform we're on
                     31: .if defined(MAINTAINER_MODE)
                     32: DISTFILES=     lc_doc.tar.gz
                     33: DISTFILES+=    lc_amd64_lx24.tar.gz
                     34: DISTFILES+=    lc_irix.tar.gz
                     35: DISTFILES+=    lc_irix64.tar.gz
                     36: DISTFILES+=    lc_linux_motif1.tar.gz
                     37: DISTFILES+=    lc_linux_motif3.tar.gz
                     38: DISTFILES+=    lc_solaris.tar.gz
                     39:
                     40: .else
                     41:
1.9     ! dmcmahil   42:
        !            43: ONLY_FOR_PLATFORM=     *-*-i386 *-*-mipsel *-*-mipsel64
        !            44: ONLY_FOR_PLATFORM+=    *-*-sparc *-*-sparc64 *-*-x86_64
1.1       dmcmahil   45:
                     46: .if (${MACHINE_ARCH} == "x86_64")
                     47: DISTNAME=      lc_amd64_lx24
1.4       dmcmahil   48: . if (${OPSYS} == "NetBSD")
                     49: DEPENDS+=      suse_openmotif>=9.1:../../emulators/${SUSE_DIR_PREFIX}_openmotif
                     50: DEPENDS+=      suse_x11>=9.1:../../emulators/${SUSE_DIR_PREFIX}_x11
                     51: . endif
1.8       dmcmahil   52: WRKSRC=                ${WRKDIR}/lc
                     53: HAVE_LCSPICE=  "@comment "
1.1       dmcmahil   54:
                     55: .elif ${MACHINE_ARCH} == "mipsel"
                     56: DISTNAME=      lc_irix
                     57:
                     58: .elif ${MACHINE_ARCH} == "mipsel64"
                     59: DISTNAME=      lc_irix64
                     60:
                     61: .elif (${MACHINE_ARCH} == "i386")
                     62: #DISTNAME=     lc_linux_motif1
                     63: DISTNAME=      lc_linux_motif3
                     64: . if (${OPSYS} == "NetBSD")
1.3       dmcmahil   65: DEPENDS+=      suse_openmotif>=9.1:../../emulators/${SUSE_DIR_PREFIX}_openmotif
                     66: DEPENDS+=      suse_x11>=9.1:../../emulators/${SUSE_DIR_PREFIX}_x11
1.1       dmcmahil   67: . endif
                     68:
1.9     ! dmcmahil   69: .elif ${MACHINE_ARCH} == "sparc" || ${MACHINE_ARCH} == "sparc64"
1.1       dmcmahil   70: DISTNAME=      lc_solaris
                     71: . if (${OPSYS} == "NetBSD")
                     72: .  if !exists(/emul/svr4/usr/lib/ld.so)
                     73: PKG_FAIL_REASON+= '${PKGNAME} requires Solaris libraries - see compat_svr4(8)'
                     74: .  endif
                     75: . endif
                     76: .endif
                     77:
1.8       dmcmahil   78: HAVE_LCSPICE?= ""
                     79:
                     80: PLIST_SUBST+=  HAVE_LCSPICE=${HAVE_LCSPICE}
                     81:
1.5       dmcmahil   82: DISTFILES=     lc_doc.tar.gz ${DISTNAME}${EXTRACT_SUFX}
                     83:
                     84: INSTALLATION_DIRS=     bin share
1.1       dmcmahil   85:
                     86: do-install:
                     87:        ${INSTALL_PROGRAM} ${WRKSRC}/bin/lc ${PREFIX}/bin/lc
                     88:        ${INSTALL_PROGRAM} ${WRKSRC}/bin/lcplot ${PREFIX}/bin/lcplot
1.8       dmcmahil   89:        if test -f ${WRKSRC}/bin/spice ; then ${INSTALL_PROGRAM} ${WRKSRC}/bin/spice ${PREFIX}/bin/lcspice ; fi
1.5       dmcmahil   90:        cd ${PREFIX}/share && ${TAR} -zxf ${DISTDIR}/${DIST_SUBDIR}/lc_doc.tar.gz
1.7       dmcmahil   91:        ${CHMOD} -R 644 ${PREFIX}/share/lc2.10
                     92:        ${CHOWN} -R ${SHAREOWN} ${PREFIX}/share/lc2.10
                     93:        ${CHGRP} -R ${SHAREGRP} ${PREFIX}/share/lc2.10
1.1       dmcmahil   94:
                     95: .endif # !MAINTAINER
                     96:
                     97: # do not include the linux stuff if we are, for example, on a Solaris box
                     98: . if (${MACHINE_ARCH} == "i386") || (${MACHINE_ARCH} == "x86_64")
                     99: .include "../../emulators/suse_linux/Makefile.application"
                    100: .endif
                    101: .include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>