[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / cad / kicad

Annotation of pkgsrc/cad/kicad/Makefile, Revision 1.40

1.40    ! ryoon       1: # $NetBSD: Makefile,v 1.39 2019/08/30 18:53:31 nia Exp $
1.1       bouyer      2: #
                      3:
1.38      bouyer      4: V=             5.1.4
1.8       bouyer      5: DISTNAME=      kicad-${V}
1.40    ! ryoon       6: PKGREVISION=   1
1.1       bouyer      7: CATEGORIES=    cad
1.33      bouyer      8: MASTER_SITES=  https://launchpad.net/kicad/5.0/${V}/+download/
1.8       bouyer      9: EXTRACT_SUFX=  .tar.xz
1.1       bouyer     10:
1.33      bouyer     11: MAINTAINER=    pkgsrc-users@NetBSD.org
1.1       bouyer     12: HOMEPAGE=      http://www.kicad-pcb.org/
                     13: COMMENT=       Schematic and PCB CAD software (stable branch)
1.33      bouyer     14: LICENSE=       gnu-gpl-v3
                     15:
                     16: DEPENDS+=      git-base-[0-9]*:../../devel/git-base
1.1       bouyer     17:
                     18: USE_PKGLOCALEDIR=      yes
1.19      jperkin    19: USE_LANGUAGES=         c c++11
1.1       bouyer     20: USE_CMAKE=             yes
                     21:
1.8       bouyer     22: CMAKE_ARGS+=           -DKICAD_REPO_NAME=stable -DKICAD_BUILD_VERSION=${V}
                     23: CMAKE_ARGS+=           -DCMAKE_BUILD_TYPE=Release -DKICAD_SKIP_BOOST=ON
1.33      bouyer     24: CMAKE_ARGS+=           -DKICAD_SPICE=OFF -DKICAD_USE_OCE=OFF
                     25: CMAKE_ARGS+=           -DKICAD_SCRIPTING=OFF -DKICAD_SCRIPTING_MODULES=OFF
                     26: CMAKE_ARGS+=           -DKICAD_SCRIPTING_ACTION_MENU=OFF
                     27: CMAKE_ARGS+=           -DKICAD_SCRIPTING_WXPYTHON=OFF
                     28:
                     29: CMAKE_MODULE_PATH_OVERRIDE = \
                     30:                        new/CMakeLists.txt
1.1       bouyer     31:
1.33      bouyer     32: PY_PATCHPLIST=         yes
1.1       bouyer     33:
                     34: SUBST_CLASSES+=                macosx
                     35: SUBST_STAGE.macosx=    pre-configure
                     36: SUBST_MESSAGE.macosx=  Eliminating Mac OS X build specific for ${PKGNAME}
1.33      bouyer     37: SUBST_FILES.macosx=    bitmap2component/CMakeLists.txt \
                     38:                        kicad/CMakeLists.txt
1.1       bouyer     39: SUBST_SED.macosx=      -e 's/[[:<:]]MACOSX_BUNDLE[[:>:]]//'
                     40:
1.5       dholland   41: .include "../../mk/bsd.prefs.mk"
                     42:
                     43: # PR 48980: no fabsl on netbsd-5
                     44: .if !empty(MACHINE_PLATFORM:MNetBSD-5.*)
                     45: SUBST_CLASSES+=                netbsd5
1.33      bouyer     46: SUBST_STAGE.netbsd5=   pre-patch
1.5       dholland   47: SUBST_MESSAGE.netbsd5= Substituting fabs() for fabsl() for NetBSD-5
                     48: SUBST_FILES.netbsd5=   pcbnew/legacy_plugin.cpp        \
                     49:                        tools/test-nm-biu-to-ascii-mm-round-tripping.cpp
                     50: SUBST_SED.netbsd5=     -e 's/fabsl/fabs/g'
                     51: .endif
                     52:
1.9       joerg      53: .include "../../mk/compiler.mk"
                     54: .if !empty(PKGSRC_COMPILER:Mclang)
                     55: CXXFLAGS+=     -Wno-error=non-pod-varargs
                     56: .endif
                     57:
1.1       bouyer     58: .include "../../devel/boost-libs/buildlink3.mk"
                     59: .include "../../devel/cmake/buildlink3.mk"
                     60: .include "../../devel/zlib/buildlink3.mk"
1.39      nia        61: .include "../../graphics/MesaLib/buildlink3.mk"
1.8       bouyer     62: .include "../../graphics/glew/buildlink3.mk"
1.33      bouyer     63: .include "../../graphics/glm/buildlink3.mk"
1.39      nia        64: .include "../../graphics/glu/buildlink3.mk"
1.8       bouyer     65: .include "../../graphics/cairo/buildlink3.mk"
1.33      bouyer     66: .include "../../lang/python/extension.mk"
1.22      mef        67: .include "../../www/curl/buildlink3.mk"
1.8       bouyer     68: .include "../../x11/wxGTK30/buildlink3.mk"
1.1       bouyer     69: .include "../../sysutils/desktop-file-utils/desktopdb.mk"
                     70: .include "../../graphics/hicolor-icon-theme/buildlink3.mk"
                     71: .include "../../mk/bsd.prefs.mk"
                     72: .include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>