File:  [cvs.NetBSD.org] / pkgsrc / biology / py-mol / Attic / Makefile
Revision 1.37: download - view: text, annotated - select for diffs
Mon Oct 12 21:51:59 2020 UTC (4 years, 6 months ago) by bacon
Branches: MAIN
CVS tags: pkgsrc-2021Q3-base, pkgsrc-2021Q3, pkgsrc-2021Q2-base, pkgsrc-2021Q2, pkgsrc-2021Q1-base, pkgsrc-2021Q1, pkgsrc-2020Q4-base, pkgsrc-2020Q4, HEAD
math/blas, math/lapack: Install interchangeable BLAS system

Install the new interchangeable BLAS system created by Thomas Orgis,
currently supporting Netlib BLAS/LAPACK, OpenBLAS, cblas, lapacke, and
Apple's Accelerate.framework.  This system allows the user to select any
BLAS implementation without modifying packages or using package options, by
setting PKGSRC_BLAS_TYPES in mk.conf. See mk/blas.buildlink3.mk for details.

This commit should not alter behavior of existing packages as the system
defaults to Netlib BLAS/LAPACK, which until now has been the only supported
implementation.

Details:

Add new mk/blas.buildlink3.mk for inclusion in dependent packages
Install compatible Netlib math/blas and math/lapack packages
Update math/blas and math/lapack MAINTAINER approved by adam@
OpenBLAS, cblas, and lapacke will follow in separate commits
Update direct dependents to use mk/blas.buildlink3.mk
Perform recursive revbump

# $NetBSD: Makefile,v 1.37 2020/10/12 21:51:59 bacon Exp $

DISTNAME=	pymol-v1.5.0.1
PKGNAME=	${PYPKGPREFIX}-${DISTNAME:S/pymol-v/mol-/}
EGG_NAME=	pymol-1.5.0.1
PKGREVISION=	8
CATEGORIES=	biology
MASTER_SITES=	${MASTER_SITE_SOURCEFORGE:=pymol/}
EXTRACT_SUFX=	.tar.bz2

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	http://www.pymol.org/
COMMENT=	Molecular Visualization System

PYTHON_VERSIONED_DEPENDENCIES=	Pmw
PYTHON_VERSIONS_ACCEPTED=	27 # not yet ported as of 1.5.0.1

WRKSRC=		${WRKDIR}/pymol

USE_TOOLS+=	csh:run

CONFLICTS=		pymol-[0-9]*

USE_LANGUAGES=	c c++

REPLACE_CSH=	test/vdiff
REPLACE_PYTHON=	test/cyg test/run test/show test/win.py modules/pmg_tk/startup/apbs_tools.py

# not used
CHECK_PORTABILITY_SKIP+=	setup/*

INSTALLATION_DIRS=	bin

# Gross hack
PYSETUPBUILDTARGET=	install ${_PYSETUPINSTALLARGS}

post-install:
	cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} PYTHONPATH=${DESTDIR}${PREFIX}/${PYSITELIB} ${PYTHONBIN} setup2.py install ${_PYSETUPINSTALLARGS}
	${INSTALL_SCRIPT} ${WRKSRC}/pymol ${DESTDIR}${PREFIX}/bin/pymol${PYVERSSUFFIX}

.include "../../devel/zlib/buildlink3.mk"
.include "../../graphics/freetype2/buildlink3.mk"
.include "../../graphics/glew/buildlink3.mk"
.include "../../graphics/freeglut/buildlink3.mk"
.include "../../graphics/png/buildlink3.mk"
.include "../../lang/python/application.mk"
.include "../../lang/python/versioned_dependencies.mk"
.include "../../lang/python/distutils.mk"
.include "../../math/py-numpy/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>