[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / biology / ncbi-blast+

Annotation of pkgsrc/biology/ncbi-blast+/Makefile, Revision 1.1

1.1     ! bacon       1: # $NetBSD$
        !             2:
        !             3: DISTNAME=      ncbi-blast-${PV}+-src
        !             4: PKGNAME=       ncbi-blast+-${PV}
        !             5: CATEGORIES=    biology
        !             6: MASTER_SITES=  https://ftp.ncbi.nlm.nih.gov/blast/executables/blast+/LATEST/ \
        !             7:                https://ftp.ncbi.nlm.nih.gov/blast/executables/blast+/${PV}/
        !             8:
        !             9: MAINTAINER=    bacon@NetBSD.org
        !            10: HOMEPAGE=      http://blast.ncbi.nlm.nih.gov/
        !            11: COMMENT=       NCBI implementation of Basic Local Alignment Search Tool
        !            12: LICENSE=       public-domain
        !            13:
        !            14: # Fix "undefined _ThreadRuneLocale" error on FreeBSD 10.0
        !            15: # Fix "unknown options" in configure
        !            16: SUBST_CLASSES+=                configure
        !            17: SUBST_STAGE.configure= post-patch
        !            18: SUBST_SED.configure+=  -e 's|-D_THREAD_SAFE|-D_THREAD_SAFE -D__RUNETYPE_INTERNAL|'
        !            19: SUBST_SED.configure+=  -e '/--infodir=DIR/d'
        !            20: SUBST_SED.configure+=  -e '/--mandir=DIR/d'
        !            21: SUBST_FILES.configure+=        ${WRKSRC}/src/build-system/configure
        !            22:
        !            23: USE_TOOLS+=    gmake
        !            24: USE_LANGUAGES= c c++
        !            25: GNU_CONFIGURE= yes
        !            26: # REPLACE_BASH=        compilers/xcode30_prj/configure
        !            27: REPLACE_PERL=  src/app/blast/legacy_blast.pl src/app/blast/update_blastdb.pl
        !            28: REPLACE_PYTHON=        src/app/winmasker/windowmasker_2.2.22_adapter.py
        !            29:
        !            30: # The test for amq can hang, but amq is not needed so just avoid the test
        !            31: # configure chooses /usr/local/bin/ar with no flags
        !            32: # Resolve a conflict with libproj by moving libs to a subdir
        !            33: CONFIGURE_ENV=         ncbi_cv_prog_amq_w=no
        !            34: CONFIGURE_ARGS+=       AR="ar cr" --without-boost
        !            35: CONFIGURE_ARGS+=       --libdir=${PREFIX}/lib/ncbi-tools++
        !            36: # MAKE_JOBS_SAFE=              no      # Intermittent issues
        !            37: WRKSRC=                        ${WRKDIR}/${DISTNAME}/c++
        !            38:
        !            39: .include "../../mk/bsd.prefs.mk"
        !            40:
        !            41: .if ${OPSYS} == NetBSD
        !            42: # statfs is deprecated on NetBSD, but still exists in libc
        !            43: # configure checks only for undefined reference, not for usability
        !            44: CONFIGURE_ENV+=                ac_cv_func_statfs=no
        !            45: .endif
        !            46:
        !            47: PV=    2.7.1
        !            48:
        !            49: post-install:
        !            50:        ${RM} ${DESTDIR}${PREFIX}/include/ncbi-tools++/*/*/.cvsignore.extra
        !            51:        ${STRIP} ${DESTDIR}${PREFIX}/lib/ncbi-tools++/*.so
        !            52:
        !            53: .include "../../devel/zlib/buildlink3.mk"
        !            54: .include "../../archivers/lzo/buildlink3.mk"
        !            55: .include "../../archivers/bzip2/buildlink3.mk"
        !            56: .include "../../devel/pcre/buildlink3.mk"
        !            57: .include "../../databases/lmdb/buildlink3.mk"
        !            58: .include "../../security/gnutls/buildlink3.mk"
        !            59: .include "../../devel/gmp/buildlink3.mk"
        !            60: .include "../../devel/libidn2/buildlink3.mk"
        !            61: .include "../../security/nettle/buildlink3.mk"
        !            62: .include "../../security/libtasn1/buildlink3.mk"
        !            63: .include "../../security/p11-kit/buildlink3.mk"
        !            64: .include "../../security/libgcrypt/buildlink3.mk"
        !            65: .include "../../databases/sqlite3/buildlink3.mk"
        !            66: .include "../../security/libgpg-error/buildlink3.mk"
        !            67: .include "../../lang/python/application.mk"
        !            68: .include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>