File:  [cvs.NetBSD.org] / pkgsrc / biology / mpqc / Makefile
Revision 1.18: download - view: text, annotated - select for diffs
Mon Oct 12 21:51:58 2020 UTC (4 years, 6 months ago) by bacon
Branches: MAIN
CVS tags: pkgsrc-2021Q1-base, pkgsrc-2021Q1, pkgsrc-2020Q4-base, pkgsrc-2020Q4, HEAD
math/blas, math/lapack: Install interchangeable BLAS system

Install the new interchangeable BLAS system created by Thomas Orgis,
currently supporting Netlib BLAS/LAPACK, OpenBLAS, cblas, lapacke, and
Apple's Accelerate.framework.  This system allows the user to select any
BLAS implementation without modifying packages or using package options, by
setting PKGSRC_BLAS_TYPES in mk.conf. See mk/blas.buildlink3.mk for details.

This commit should not alter behavior of existing packages as the system
defaults to Netlib BLAS/LAPACK, which until now has been the only supported
implementation.

Details:

Add new mk/blas.buildlink3.mk for inclusion in dependent packages
Install compatible Netlib math/blas and math/lapack packages
Update math/blas and math/lapack MAINTAINER approved by adam@
OpenBLAS, cblas, and lapacke will follow in separate commits
Update direct dependents to use mk/blas.buildlink3.mk
Perform recursive revbump

# $NetBSD: Makefile,v 1.18 2020/10/12 21:51:58 bacon Exp $

DISTNAME=	mpqc-2.3.1
PKGREVISION=	10
CATEGORIES=	biology
MASTER_SITES=	${MASTER_SITE_SOURCEFORGE:=mpqc/}
EXTRACT_SUFX=	.tar.bz2

MAINTAINER=	asau@inbox.ru
HOMEPAGE=	http://www.mpqc.org/
COMMENT=	The Massively Parallel Quantum Chemistry Program

USE_LANGUAGES=		c c++ fortran77
PKGSRC_FORTRAN=		f2c # XXX force f2c for now
GNU_CONFIGURE=		yes
CONFIGURE_ARGS+=	--with-libdirs="-L${PREFIX}/lib ${COMPILER_RPATH_FLAG}${PREFIX}/lib"	# fixme
#CONFIGURE_ARGS=	-without-f77	# this doesn't work out of the box
CONFIGURE_ENV=		ac_cv_prog_WISH=${REPLACE.wish.new}
USE_TOOLS+=		perl:run
USE_LIBTOOL=		yes

USE_TOOLS+=	gmake
BUILD_TARGET=	default

# This is strange, yet...
INSTALL_MAKE_FLAGS=	installroot=${DESTDIR}

REPLACE_PERL=	src/bin/mpqc/ccarun.in src/bin/mpqc/mpqcrun.in

# Don't introduce Tk dependency for minor things, just leave a hook:
REPLACE_WISH=		src/bin/molrender/tkmolrender.in
CHECK_INTERPRETER_SKIP=	bin/tkmolrender

# optional:
# MPI, niama-config, libr12, libderiv
.include "../../devel/libexecinfo/buildlink3.mk" # optional
.include "../../mk/dlopen.buildlink3.mk" # optional?
.include "../../math/libint/buildlink3.mk" # optional

.include "../../x11/tk/interpreter.mk"

.include "../../mk/blas.buildlink3.mk"
.include "../../mk/pthread.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>