[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / audio / terminatorx

File: [cvs.NetBSD.org] / pkgsrc / audio / terminatorx / Makefile (download)

Revision 1.6, Sat Mar 4 21:28:58 2006 UTC (18 years ago) by jlam
Branch: MAIN
Changes since 1.5: +2 -2 lines

Point MAINTAINER to pkgsrc-users@NetBSD.org in the case where no
developer is officially maintaining the package.

The rationale for changing this from "tech-pkg" to "pkgsrc-users" is
that it implies that any user can try to maintain the package (by
submitting patches to the mailing list).  Since the folks most likely
to care about the package are the folks that want to use it or are
already using it, this would leverage the energy of users who aren't
developers.

# $NetBSD: Makefile,v 1.6 2006/03/04 21:28:58 jlam Exp $
#

DISTNAME=	terminatorX-3.82
PKGNAME=	${DISTNAME:S/X/x/}
PKGREVISION=	2
CATEGORIES=	audio
MASTER_SITES=	http://terminatorx.cx/dist/
EXTRACT_SUFX=	.tar.bz2

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	http://terminatorx.cx/
COMMENT=	Realtime audio synthesizer

DEPENDS+=	mpg123-[0-9]*:../../audio/mpg123
DEPENDS+=	sox-[0-9]*:../../audio/sox
DEPENDS+=	vorbis-tools-[0-9]*:../../audio/vorbis-tools

USE_LIBTOOL=		yes
GNU_CONFIGURE=		yes

LIBS+=			${LIBOSSAUDIO}
CONFIGURE_ARGS+=	--disable-alsa

SUBST_CLASSES+=		oss
SUBST_STAGE.oss=	post-patch
SUBST_FILES.oss=	src/tX_global.c
SUBST_SED.oss=		-e "s,/dev/dsp,${DEVOSSAUDIO},g"
SUBST_MESSAGE.oss=	"Fixing hardcoded audio device."

.include "../../audio/ladspa/buildlink3.mk"
.include "../../audio/libaudiofile/buildlink3.mk"
.include "../../audio/libvorbis/buildlink3.mk"
.include "../../audio/libmad/buildlink3.mk"
.include "../../textproc/libxml2/buildlink3.mk"
.include "../../textproc/scrollkeeper/omf.mk"
.include "../../x11/gtk2/buildlink3.mk"

.include "../../mk/ossaudio.buildlink3.mk"
.include "../../mk/pthread.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"