[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / audio / sptk

File: [cvs.NetBSD.org] / pkgsrc / audio / sptk / Makefile (download)

Revision 1.7, Sun Jul 10 12:06:21 2016 UTC (7 years, 2 months ago) by mef
Branch: MAIN
CVS Tags: pkgsrc-2019Q4-base, pkgsrc-2019Q4, pkgsrc-2019Q3-base, pkgsrc-2019Q3, pkgsrc-2019Q2-base, pkgsrc-2019Q2, pkgsrc-2019Q1-base, pkgsrc-2019Q1, pkgsrc-2018Q4-base, pkgsrc-2018Q4, pkgsrc-2018Q3-base, pkgsrc-2018Q3, pkgsrc-2018Q2-base, pkgsrc-2018Q2, pkgsrc-2018Q1-base, pkgsrc-2018Q1, pkgsrc-2017Q4-base, pkgsrc-2017Q4, pkgsrc-2017Q3-base, pkgsrc-2017Q3, pkgsrc-2017Q2-base, pkgsrc-2017Q2, pkgsrc-2017Q1-base, pkgsrc-2017Q1, pkgsrc-2016Q4-base, pkgsrc-2016Q4, pkgsrc-2016Q3-base, pkgsrc-2016Q3
Changes since 1.6: +2 -2 lines

Updated audio/sptk 3.6 to 3.9
-----------------------------
Version 3.9:
 * support full covariance for 'gmmp' command.
 * add -B, -c1 and -c2 option to 'gmmp' command to specify block size and structure of covariance matrix.
 * change temporary file path for csh.
 * bug fixes.

Version 3.8:
 * add 'c2ndps' command for transform from cepstrum to negative derivative of phrase spectrum.
 * add 'mgclsp2sp' command for transform from LSP to spectrum.
 * add 'ndps2c' command for transform from negative derivative of phrase spectrum to cepstrum.
 * add 'wavjoin' command to save stereo wav file.
 * add 'wavsplit' command to load stereo wav file.
 * add -V option to 'dtw' command for loading DTW results.
 * add -e option to calculate inverse matrix stably for 'delta' and 'vc' commands.
 * support MAP estimation in 'gmm' command.
 * replace -i option to -q option for 'lsp2lpc,' 'lspcheck,' and 'mgclsp2mgc' commands.
 * change -c option of 'mlsacheck' command.
 * update swipe and hts_engine API.
 * bug fixes.

Version 3.7:
 * add 'vc' command to perform GMM-based voice conversion.
 * add 'lsp2sp' command to transform LSP coefficients to spectrum.
 * add -R option to 'mlsacheck' command to specify threshold value.
 * add -f option to 'gmmp' command to specify full covariance matrix.
 * add -M, -c1 and -c2 option to 'gmm' command to specify block size and structure of covariance matrix.
 * add -n option to 'delta' command to specify order of regression polynomial.
 * add -magic and -MAGIC option to 'rmse' command to delete and substitute magic number.
 * add -n and -t option to 'rmse' command to specify order and number of vector, respectively.
 * add -POWX, -LOGX option, and new constant (semitone) to 'sopr' command.
 * add -l option to 'decimate' and 'interpolate' command to specify length of vector.
 * add -g and -G option to 'lspcheck' command to check value of gain.
 * add -L option to 'lspcheck' command to specify log gain.
 * add -n option to 'mgc2mgclsp' command to specify split number of unit circle.
 * add -p and -d to 'mgc2mgclsp' command to specify maximum number and end condition of interpolation.
 * add -x 16, 22, 24 and 48 option of 'glogsp' and 'grlogsp' command to specify more x-axis scales.
 * add filter coefficients for 7:4 down-sampling, 3:5 and 7:8 up-sampling.
 * unify option to specify log gain into -L option.
 * fix -c option of 'mlsacheck' command to specify the type of modification of filter coefficients.
 * bug fixes.

# $NetBSD: Makefile,v 1.7 2016/07/10 12:06:21 mef Exp $
#

DISTNAME=	SPTK-3.9
PKGNAME=	${DISTNAME:tl}
CATEGORIES=	audio
MASTER_SITES=	${MASTER_SITE_SOURCEFORGE:=sp-tk/}
DISTFILES=	${DEFAULT_DISTFILES}
DISTFILES+=	SPTKref-${PKGVERSION_NOREV}.pdf
DISTFILES+=	SPTKexamples-${PKGVERSION_NOREV}.pdf

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	http://sp-tk.sourceforge.net/
COMMENT=	Suite of speech signal processing tools
LICENSE=	modified-bsd

GNU_CONFIGURE=	yes
USE_TOOLS+=	csh:run

GNU_CONFIGURE_PREFIX=	${PREFIX}/SPTK
CONFIGURE_ENV+=		CSH=${CSH}
CONFIGURE_ARGS+=	--disable-da

INSTALLATION_DIRS+=	share/doc/sptk

post-install:
	${INSTALL_DATA} ${WRKSRC}/README ${DESTDIR}${PREFIX}/share/doc/sptk
	${INSTALL_DATA} ${WRKDIR}/SPTKref-${PKGVERSION_NOREV}.pdf ${DESTDIR}${PREFIX}/share/doc/sptk
	${INSTALL_DATA} ${WRKDIR}/SPTKexamples-${PKGVERSION_NOREV}.pdf ${DESTDIR}${PREFIX}/share/doc/sptk

.include "../../x11/libX11/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"