[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / audio / sox

File: [cvs.NetBSD.org] / pkgsrc / audio / sox / Makefile (download)

Revision 1.65, Sat Jan 18 23:30:05 2020 UTC (4 years, 2 months ago) by rillig
Branch: MAIN
Changes since 1.64: +2 -2 lines

all: migrate several HOMEPAGEs to https

pkglint --only "https instead of http" -r -F

With manual adjustments afterwards since pkglint 19.4.4 fixed a few
indentations in unrelated lines.

This mainly affects projects hosted at SourceForce, as well as
freedesktop.org, CTAN and GNU.

# $NetBSD: Makefile,v 1.65 2020/01/18 23:30:05 rillig Exp $

DISTNAME=	sox-14.4.2
PKGREVISION=	2
CATEGORIES=	audio
MASTER_SITES=	${MASTER_SITE_SOURCEFORGE:=sox/}

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	https://sox.sourceforge.net/
COMMENT=	SOund eXchange - universal sound sample translator
LICENSE=	gnu-lgpl-v2.1 AND gnu-gpl-v2

#USE_CMAKE=		yes
USE_LANGUAGES=		c c++
USE_LIBTOOL=		yes
USE_TOOLS+=		pkg-config
GNU_CONFIGURE=		yes
CONFIGURE_ARGS+=	--disable-gomp
CONFIGURE_ARGS+=	--without-libltdl
CONFIGURE_ENV+=		ac_cv_func_fmemopen=no

PKGCONFIG_OVERRIDE+=	sox.pc.in

SUBST_CLASSES+=		gsm
SUBST_FILES.gsm=	configure src/gsm.c src/wav.c CMakeLists.txt
SUBST_SED.gsm=		-e "s!gsm/gsm.h!gsm.h!"
SUBST_STAGE.gsm=	pre-configure

.include "options.mk"

# failed to convert strong functions and variables: Invalid type identifier
CTF_FILES_SKIP+=	lib/libsox.so.3.0.0

.include "../../audio/flac/buildlink3.mk"
.include "../../audio/gsm/buildlink3.mk"
.include "../../audio/libmad/buildlink3.mk"
.include "../../audio/libsamplerate/buildlink3.mk"
.include "../../audio/libsndfile/buildlink3.mk"
.include "../../audio/libvorbis/buildlink3.mk"
.include "../../devel/zlib/buildlink3.mk"
.include "../../graphics/png/buildlink3.mk"
.include "../../sysutils/file/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"