File:
[cvs.NetBSD.org] /
pkgsrc /
audio /
openal-soft /
Makefile
Revision
1.34:
download - view:
text,
annotated -
select for diffs
Sun Apr 23 09:13:19 2023 UTC (19 months, 3 weeks ago) by
wiz
Branches:
MAIN
CVS tags:
HEAD
openal-soft: update to 1.23.1.
openal-soft-1.23.1:
Implemented the AL_SOFT_UHJ_ex extension.
Implemented the AL_SOFT_buffer_length_query extension.
Implemented the AL_SOFT_source_start_delay extension.
Implemented the AL_EXT_STATIC_BUFFER extension.
Fixed compiling with certain older versions of GCC.
Fixed compiling as a submodule.
Fixed compiling with newer versions of Oboe.
Improved EAX effect version switching.
Improved the quality of the reverb modulator.
Improved performance of the cubic resampler.
Added a compatibility option to restore AL_SOFT_buffer_sub_data. The option
disables AL_EXT_SOURCE_RADIUS due to incompatibility.
Reduced CPU usage when EAX is initialized and FXSlot0 or FXSlot1 are not
used.
Reduced memory usage for ADPCM buffer formats. They're no longer converted
to 16-bit samples on load.
# $NetBSD: Makefile,v 1.34 2023/04/23 09:13:19 wiz Exp $
DISTNAME= openal-soft-1.23.1
CATEGORIES= audio
MASTER_SITES= https://openal-soft.org/openal-releases/
EXTRACT_SUFX= .tar.bz2
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= https://openal-soft.org/
COMMENT= Software implementation of the OpenAL 3D audio API
LICENSE= gnu-lgpl-v2
# c++20 not yet supported by mk/
USE_LANGUAGES= c c++
USE_TOOLS+= pkg-config gmake
# uses [[likely]] from C++20
GCC_REQD+= 9
PKGCONFIG_OVERRIDE+= openal.pc.in
PKG_SYSCONFSUBDIR= openal
CMAKE_ARGS+= -DALSOFT_EXAMPLES=OFF
CMAKE_ARGS+= -DALSOFT_UTILS=ON
CMAKE_ARGS+= -DALSOFT_NO_CONFIG_UTIL=ON
CMAKE_ARGS+= -DALSOFT_RTKIT=OFF
CFLAGS+= -DSYS_CONF_DIR="\"${PKG_SYSCONFDIR}\""
CFLAGS.NetBSD+= -D_NETBSD_SOURCE
CFLAGS.SunOS+= -D__EXTENSIONS__
BUILDLINK_TRANSFORM+= rm:-Wall
CONF_FILES+= ${PREFIX}/share/openal/alsoftrc.sample ${PKG_SYSCONFDIR}/alsoft.conf
.include "../../mk/bsd.prefs.mk"
.if ${OPSYS} == "SunOS" || ${OPSYS} == "NetBSD"
CMAKE_ARGS+= -DALSOFT_BACKEND_SOLARIS=ON
CMAKE_ARGS+= -DALSOFT_REQUIRE_SOLARIS=ON
.endif
.include "../../mk/oss.buildlink3.mk"
.if ${OSS_TYPE} != "none"
CMAKE_ARGS+= -DALSOFT_BACKEND_OSS=ON
CMAKE_ARGS+= -DALSOFT_REQUIRE_OSS=ON
SUBST_CLASSES+= oss
SUBST_STAGE.oss= pre-configure
SUBST_MESSAGE.oss= Fixing default OSS device references.
SUBST_FILES.oss= alc/backends/oss.cpp
SUBST_SED.oss= -e 's,/dev/dsp,${DEVOSSAUDIO},'
.endif
.include "options.mk"
post-install:
${RM} ${DESTDIR}${PREFIX}/include/AL/al.h.orig
.include "../../devel/cmake/build.mk"
.include "../../audio/libmysofa/buildlink3.mk"
.include "../../mk/dlopen.buildlink3.mk"
.include "../../mk/pthread.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"
CVSweb <webmaster@jp.NetBSD.org>