[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / audio / nas

Annotation of pkgsrc/audio/nas/Makefile, Revision 1.69

1.69    ! joerg       1: # $NetBSD: Makefile,v 1.68 2006/10/22 16:03:18 rillig Exp $
1.1       augustss    2:
1.61      markd       3: DISTNAME=      nas-1.8.src
1.10      jlam        4: PKGNAME=       ${DISTNAME:S/.src//}
1.62      jlam        5: PKGREVISION=   1
1.1       augustss    6: CATEGORIES=    audio
1.46      wiz         7: MASTER_SITES=  http://nas.codebrilliance.com/nas/ \
1.47      adam        8:                ftp://ftp.uni-duisburg.de/Sound/NAS/
1.1       augustss    9:
1.51      markd      10: MAINTAINER=    markd@NetBSD.org
1.10      jlam       11: HOMEPAGE=      http://radscan.com/nas.html
1.12      wiz        12: COMMENT=       Network Audio System
1.29      wulf       13:
1.49      fredb      14: DEPENDS+=      p5-perl-headers-${OS_VERSION}{,nb*}:../../devel/p5-perl-headers
1.6       frueauf    15:
1.45      minskim    16: PKG_INSTALLATION_TYPES=        overwrite pkgviews
                     17:
1.47      adam       18: WRKSRC=                        ${WRKDIR}/${PKGNAME_NOREV}
1.62      jlam       19: USE_TOOLS+=            gmake perl:run
1.22      jlam       20: USE_IMAKE=             yes
1.68      rillig     21: MAKE_FLAGS+=           MANPATH=${PREFIX}/${PKGMANDIR}
1.11      fredb      22:
1.20      markd      23: PKG_SYSCONFSUBDIR=     nas
1.27      wulf       24:
1.60      markd      25: REPLACE_PERL+=         clients/audio/auscope/auscope
1.33      grant      26:
1.66      rillig     27: SUBST_CLASSES+=                sysconf
1.60      markd      28: SUBST_STAGE.sysconf=   pre-configure
                     29: SUBST_FILES.sysconf=   config/NetAudio.def
                     30: SUBST_SED.sysconf=     -e "s|@PKG_SYSCONFDIR@|${PKG_SYSCONFDIR}|g"
                     31:
1.66      rillig     32: SUBST_CLASSES+=                ossaudio
1.60      markd      33: SUBST_STAGE.ossaudio=  pre-configure
                     34: SUBST_FILES.ossaudio=  server/nasd.conf.eg server/dda/voxware/auvoxware.c
                     35: SUBST_SED.ossaudio=    -e "s|@DEVOSSAUDIO@|${DEVOSSAUDIO}|g"
                     36:
1.66      rillig     37: SUBST_CLASSES+=                mungeman
1.60      markd      38: SUBST_STAGE.mungeman=  pre-configure
                     39: SUBST_FILES.mungeman=  config/mungeman
                     40: SUBST_SED.mungeman=    -e 's|^ *\#|\#|g'
1.37      sketch     41:
1.50      tv         42: .include "../../mk/bsd.prefs.mk"
                     43:
1.64      minskim    44: .if defined(UNPRIVILEGED) && !empty(UNPRIVILEGED:M[Yy][Ee][Ss])
                     45: SUBST_CLASSES+=                owngrp
                     46: SUBST_MESSAGE.owngrp=  Fixing hardcoded owner/group.
                     47: SUBST_STAGE.owngrp=    post-configure
1.65      minskim    48: SUBST_FILES.owngrp=    clients/audio/auconvert/Makefile \
                     49:                        clients/audio/auctl/Makefile \
                     50:                        clients/audio/audemo/Makefile \
                     51:                        clients/audio/audial/Makefile \
                     52:                        clients/audio/auedit/Makefile \
                     53:                        clients/audio/auinfo/Makefile \
                     54:                        clients/audio/aupanel/Makefile \
                     55:                        clients/audio/auphone/Makefile \
                     56:                        clients/audio/auplay/Makefile \
                     57:                        clients/audio/aurecord/Makefile \
1.64      minskim    58:                        clients/audio/auscope/Makefile \
1.65      minskim    59:                        clients/audio/autool/Makefile \
                     60:                        clients/audio/auwave/Makefile \
                     61:                        clients/audio/examples/Makefile \
                     62:                        clients/audio/util/Makefile \
                     63:                        clients/audio/widgets/Makefile \
1.64      minskim    64:                        clients/audio/Makefile \
                     65:                        clients/Makefile config/Makefile doc/Makefile \
                     66:                        doc/man/lib/Makefile doc/man/Makefile \
                     67:                        include/audio/Makefile include/Makefile \
1.65      minskim    68:                        lib/Makefile lib/audio/Makefile \
1.64      minskim    69:                        Makefile server/Makefile
                     70: SUBST_SED.owngrp=      -e 's/-c -o root -g wheel/-c -o ${UNPRIVILEGED_USER} -g ${UNPRIVILEGED_GROUP}/g'
                     71: .endif
                     72:
1.55      markd      73: .if ${OPSYS} == "SunOS"
                     74: post-install:
1.61      markd      75:        ${LN} -s ${PREFIX}/lib/libaudio.so.2.4 ${PREFIX}/lib/libaudio.so.2
1.55      markd      76: .endif
                     77:
1.11      fredb      78: PLIST_SRC=     ${PKGDIR}/PLIST.clients
1.50      tv         79:
                     80: .if ${OPSYS} != "Interix"
                     81: .  if (${MACHINE_ARCH} == "i386") || \
1.60      markd      82:       (${MACHINE_ARCH} == "x86_64") || \
1.67      markd      83:       (${MACHINE_ARCH} == "sparc64") || \
1.50      tv         84:       (${MACHINE_ARCH} == "sparc")
1.59      jlam       85: .    include "../../mk/oss.buildlink3.mk"
1.21      jlam       86: EGDIR=         ${PREFIX}/share/examples/nas
1.55      markd      87: CONF_FILES=    ${EGDIR}/nasd.conf.eg ${PKG_SYSCONFDIR}/nasd.conf
                     88: .    if ${OPSYS} != "SunOS"
1.11      fredb      89: PLIST_SRC+=    ${PKGDIR}/PLIST.voxware
1.55      markd      90: .    endif
                     91: PLIST_SRC+=    ${PKGDIR}/PLIST.server
1.50      tv         92: .  endif
1.11      fredb      93: .endif
1.1       augustss   94:
1.63      minskim    95: pre-configure:
                     96:        cd ${WRKSRC}/config && ${SETENV} ${CONFIGURE_ENV} ./configure
                     97:
1.69    ! joerg      98: .include "../../x11/libX11/buildlink3.mk"
        !            99: .include "../../x11/libXaw/buildlink3.mk"
        !           100: .include "../../x11/libXp/buildlink3.mk"
        !           101:
1.4       agc       102: .include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>