[BACK]Return to Makefile.common CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / audio / mpg123

File: [cvs.NetBSD.org] / pkgsrc / audio / mpg123 / Makefile.common (download)

Revision 1.54, Mon Jul 6 15:33:54 2020 UTC (3 years, 8 months ago) by adam
Branch: MAIN
Changes since 1.53: +2 -2 lines

mpg123: updated to 1.26.2

version 1.26.2:
Some refinements.
Enable terminal control by default only when both input and output are connected to a terminal. This avoids messing with terminal settings when piping stderr to a pager, which takes over terminal input anyway, while mpg123 still thinks it got control.
Windows build fixes for UWP and without GetThreadErrorMode when not building modules, thanks to Steve LHomme.
Android build fix regarding off64_t use, thanks to Steve LHomme.
More CMake build fixes thanks to David Callu (bug 290).
Use PROG_LIBS for output modules, to reinstate not necessarily proper but previous behaviour and fix FreeBSD port build (bug 291).
Refine LFS support in libsyn123, avoiding architecture-dependent syn123.h (debian bug 963205).

# $NetBSD: Makefile.common,v 1.54 2020/07/06 15:33:54 adam Exp $
#
# used by audio/mpg123-nas/Makefile
# used by audio/mpg123-oss/Makefile
# used by audio/mpg123-pulse/Makefile
# used by audio/mpg123-sun/Makefile

DISTNAME=	mpg123-1.26.2
PKGNAME?=	${DISTNAME:C/[[:alnum:]]*/&-${MPG123_MODULE}/}
CATEGORIES=	audio
MASTER_SITES=	${MASTER_SITE_SOURCEFORGE:=mpg123/}
EXTRACT_SUFX=	.tar.bz2

MAINTAINER=	martin@NetBSD.org
HOMEPAGE=	https://www.mpg123.org/
COMMENT?=	Contains the ${MPG123_MODULE} module for mpg123
LICENSE=	gnu-lgpl-v2.1

USE_LANGUAGES=		c99
USE_LIBTOOL?=		yes
USE_TOOLS+=		pkg-config gmake
GNU_CONFIGURE?=		yes
CONFIGURE_ARGS+=	--enable-modules=yes
CONFIGURE_ARGS+=	--with-optimization=0	# our CFLAGS are good enough
CONFIGURE_ENV+=		BUILD_${MPG123_MODULE:tu}=yes
CONFIGURE_ENV+=		MPG123_MODULE=${MPG123_MODULE:Q}

DISTINFO_FILE=		${.CURDIR}/../../audio/mpg123/distinfo

CPPFLAGS.SunOS+=	-D_XOPEN_SOURCE=600 -D__EXTENSIONS__

.if !defined(MPG123_BUILDING_BASE)
INSTALLATION_DIRS+=	lib/mpg123
LIBS+=			-lmpg123
BUILD_TARGET=		src/libout123/modules/output_${MPG123_MODULE}.la
PATCHDIR=		${.CURDIR}/../../audio/mpg123/patches
do-install:
	${LIBTOOL} --mode=install ${INSTALL_LIB} \
		${WRKSRC}/src/libout123/modules/output_${MPG123_MODULE}.la \
		${DESTDIR}${PREFIX}/lib/mpg123
.endif

#.include "../../devel/libltdl/buildlink3.mk"
.include "../../mk/dlopen.buildlink3.mk"