[BACK]Return to Makefile.common CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / audio / mpg123

File: [cvs.NetBSD.org] / pkgsrc / audio / mpg123 / Makefile.common (download)

Revision 1.49, Sat Jul 27 15:14:40 2019 UTC (4 years, 8 months ago) by nia
Branch: MAIN
Changes since 1.48: +3 -3 lines

mpg123: Update to 1.25.11

libmpg123:
* Fix out-of-bounds reads in ID3 parser for unsynced frames. (oss-fuzz-bug 15852)
* Fix out-of-bounds read for RVA2 frames with non-delimited identifier. (oss-fuzz-bug 15852)
* Fix implementation-defined parsing of RVA2 values. (oss-fuzz-bug 15862)
* Fix undefined parsing of APE header for skipping. Also prevent endless loop on premature end of supposed APE header. (oss-fuzz-bug 15864)
* Fix some syntax to make pedantic compiler happy.

The serious bugs trigger Denial of Service either via the nasty endless
loop in supposed APE tags or by crashes if the invalid reads hit a
diagnostic by the OS or, more likely, a security mechanism like the
sanitizer instrumentation that enabled finding the bugs.

I do not have CVE numbers for these bugs.
I rather fix the bugs than name them. Just update, will you?

# $NetBSD: Makefile.common,v 1.49 2019/07/27 15:14:40 nia Exp $
#
# used by audio/mpg123-arts/Makefile
# used by audio/mpg123-esound/Makefile
# used by audio/mpg123-nas/Makefile
# used by audio/mpg123-oss/Makefile
# used by audio/mpg123-pulse/Makefile
# used by audio/mpg123-sun/Makefile

DISTNAME=	mpg123-1.25.11
PKGNAME?=	${DISTNAME:C/[[:alnum:]]*/&-${MPG123_MODULE}/}
CATEGORIES=	audio
MASTER_SITES=	${MASTER_SITE_SOURCEFORGE:=mpg123/}
EXTRACT_SUFX=	.tar.bz2

MAINTAINER=	martin@NetBSD.org
HOMEPAGE=	https://www.mpg123.org/
COMMENT?=	Contains the ${MPG123_MODULE} module for mpg123
LICENSE=	gnu-lgpl-v2.1

USE_LANGUAGES=		c99
USE_LIBTOOL?=		yes
USE_TOOLS+=		pkg-config gmake
GNU_CONFIGURE?=		yes
CONFIGURE_ARGS+=	--enable-modules=yes
CONFIGURE_ARGS+=	--with-optimization=0	# our CFLAGS are good enough
CONFIGURE_ENV+=		BUILD_${MPG123_MODULE:tu}=yes
CONFIGURE_ENV+=		MPG123_MODULE=${MPG123_MODULE:Q}

DISTINFO_FILE=		${.CURDIR}/../../audio/mpg123/distinfo

CPPFLAGS.SunOS+=	-D_XOPEN_SOURCE=600 -D__EXTENSIONS__

.if !defined(MPG123_BUILDING_BASE)
INSTALLATION_DIRS+=	lib/mpg123
LIBS+=			-lmpg123
BUILD_TARGET=		src/libout123/modules/output_${MPG123_MODULE}.la
PATCHDIR=		${.CURDIR}/../../audio/mpg123/patches
do-install:
	${LIBTOOL} --mode=install ${INSTALL_LIB} \
		${WRKSRC}/src/libout123/modules/output_${MPG123_MODULE}.la \
		${DESTDIR}${PREFIX}/lib/mpg123
.endif

#.include "../../devel/libltdl/buildlink3.mk"
.include "../../mk/dlopen.buildlink3.mk"