[BACK]Return to Makefile.common CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / audio / mpg123

File: [cvs.NetBSD.org] / pkgsrc / audio / mpg123 / Makefile.common (download)

Revision 1.47, Thu Dec 14 11:42:05 2017 UTC (6 years, 4 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2018Q1-base, pkgsrc-2018Q1, pkgsrc-2017Q4-base, pkgsrc-2017Q4
Changes since 1.46: +2 -2 lines

mpg123: updated to 1.25.8

1.25.8
------
- mpg123:
-- Also disable cursor/video games for empty TERM (not just unset and dumb).
- libmpg123:
-- Accept changing mode extension bits when looking for next header for
   detecting free-format streams (bug 257).
-- Fix compute_bpf() for free format streams (needed to estimate track
   length and working fuzzy seeking in absence of an Info tag).

# $NetBSD: Makefile.common,v 1.47 2017/12/14 11:42:05 adam Exp $
#
# used by audio/mpg123-arts/Makefile
# used by audio/mpg123-esound/Makefile
# used by audio/mpg123-nas/Makefile
# used by audio/mpg123-oss/Makefile
# used by audio/mpg123-pulse/Makefile
# used by audio/mpg123-sun/Makefile

DISTNAME=	mpg123-1.25.8
PKGNAME?=	${DISTNAME:C/[[:alnum:]]*/&-${MPG123_MODULE}/}
CATEGORIES=	audio
MASTER_SITES=	${MASTER_SITE_SOURCEFORGE:=mpg123/}
EXTRACT_SUFX=	.tar.bz2

MAINTAINER=	martin@NetBSD.org
HOMEPAGE=	http://www.mpg123.org/
COMMENT?=	Contains the ${MPG123_MODULE} module for mpg123
LICENSE=	gnu-lgpl-v2.1

USE_LANGUAGES=		c99
USE_LIBTOOL?=		yes
USE_TOOLS+=		pkg-config gmake
GNU_CONFIGURE?=		yes
CONFIGURE_ARGS+=	--enable-modules=yes
CONFIGURE_ARGS+=	--with-optimization=0	# our CFLAGS are good enough
CONFIGURE_ENV+=		BUILD_${MPG123_MODULE:tu}=yes
CONFIGURE_ENV+=		MPG123_MODULE=${MPG123_MODULE:Q}

DISTINFO_FILE=		${.CURDIR}/../../audio/mpg123/distinfo

CPPFLAGS.SunOS+=	-D_XOPEN_SOURCE=600 -D__EXTENSIONS__

.if !defined(MPG123_BUILDING_BASE)
INSTALLATION_DIRS+=	lib/mpg123
LIBS+=			-lmpg123
BUILD_TARGET=		src/libout123/modules/output_${MPG123_MODULE}.la
PATCHDIR=		${.CURDIR}/../../audio/mpg123/patches
do-install:
	${LIBTOOL} --mode=install ${INSTALL_LIB} \
		${WRKSRC}/src/libout123/modules/output_${MPG123_MODULE}.la \
		${DESTDIR}${PREFIX}/lib/mpg123
.endif

#.include "../../devel/libltdl/buildlink3.mk"
.include "../../mk/dlopen.buildlink3.mk"