[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / audio / liveice

File: [cvs.NetBSD.org] / pkgsrc / audio / liveice / Makefile (download)

Revision 1.12, Sat Mar 4 21:28:56 2006 UTC (18 years ago) by jlam
Branch: MAIN
Changes since 1.11: +2 -2 lines

Point MAINTAINER to pkgsrc-users@NetBSD.org in the case where no
developer is officially maintaining the package.

The rationale for changing this from "tech-pkg" to "pkgsrc-users" is
that it implies that any user can try to maintain the package (by
submitting patches to the mailing list).  Since the folks most likely
to care about the package are the folks that want to use it or are
already using it, this would leverage the energy of users who aren't
developers.

# $NetBSD: Makefile,v 1.12 2006/03/04 21:28:56 jlam Exp $
#

DISTNAME=	liveice
PKGNAME=	liveice-0.20001121
PKGREVISION=	1
CATEGORIES=	audio
MASTER_SITES=	http://star.arm.ac.uk/~spm/software/

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	http://star.arm.ac.uk/~spm/software/liveice.html
COMMENT=	Source client for Icecast

DEPENDS+=	mpg123-0.5*:../../audio/mpg123
DEPENDS+=	lame-3.*:../../audio/lame
DEPENDS+=	tk>=8.0:../../x11/tk

GNU_CONFIGURE=	YES
DIST_SUBDIR=	liveice-0.20001121
LIBS+=		${LIBOSSAUDIO}

INSTALLATION_DIRS=	bin

do-install:
	${INSTALL_PROGRAM} ${WRKSRC}/liveice ${PREFIX}/bin
	( ${ECHO} '#!${LOCALBASE}/bin/wish' ; \
	  ${TAIL} +2 ${WRKSRC}/liveiceconfigure.tk \
	) >${PREFIX}/bin/liveiceconfigure.tk
	${CHGRP} ${BINGRP}	${PREFIX}/bin/liveiceconfigure.tk
	${CHOWN} ${BINOWN}	${PREFIX}/bin/liveiceconfigure.tk
	${CHMOD} ${BINMODE}	${PREFIX}/bin/liveiceconfigure.tk
	${INSTALL_DATA_DIR} ${PREFIX}/share/doc/liveice
	for i in README.frontend README.liveice README.quickstart \
		README.xingmp3enc README_new_mixer.txt ; \
	do \
		${INSTALL_DATA} ${WRKSRC}/$$i ${PREFIX}/share/doc/liveice ; \
	done

.include "../../mk/ossaudio.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"