[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / audio / libcanberra

File: [cvs.NetBSD.org] / pkgsrc / audio / libcanberra / Makefile (download)

Revision 1.47, Thu Nov 29 11:20:18 2018 UTC (5 years, 4 months ago) by prlw1
Branch: MAIN
CVS Tags: pkgsrc-2019Q2-base, pkgsrc-2019Q2, pkgsrc-2019Q1-base, pkgsrc-2019Q1, pkgsrc-2018Q4-base, pkgsrc-2018Q4
Changes since 1.46: +4 -5 lines

Update libcanberra to 0.30

Motivation: Version 0.30 released; Port to GStreamer 1.0.

I believe the warning in doc/TODO:

   o libcanberra-0.28 [drops support for GNOME2; don't update for now -- wiz]

comes from:

Version 0.28 released; Hook properly into GNOME 3.0 sessions; this
drops support for GNOME 2.0 sessions, but not applications.

which essentially comes from:

index aa0a3a3..210d2c1 100644
--- a/src/libcanberra-login-sound.desktop.in
+++ b/src/libcanberra-login-sound.desktop.in
@@ -4,6 +4,6 @@ Name=GNOME Login Sound
 Comment=Plays a sound whenever you log in
 Exec=@bindir@/canberra-gtk-play --id="desktop-login" --description="GNOME Login"
 OnlyShowIn=GNOME;
-AutostartCondition=GNOME /desktop/gnome/sound/event_sounds
+AutostartCondition=GSettings org.gnome.desktop.sound event-sounds
 X-GNOME-Autostart-Phase=Application
 X-GNOME-Provides=login-sound

AFAICT, given that I have not found a desktop-login audio file anywhere
in pkgsrc (there is a login file), --id="desktop-login" will never match,
so we can't break something which doesn't work. If this analysis is wrong,
changing one line in 2 .desktop files is trivial. Relying on
gstreamer 0.10 working is worse.

# $NetBSD: Makefile,v 1.47 2018/11/29 11:20:18 prlw1 Exp $

DISTNAME=	libcanberra-0.30
CATEGORIES=	audio
MASTER_SITES=	http://0pointer.de/lennart/projects/libcanberra/
EXTRACT_SUFX=	.tar.xz

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	http://0pointer.de/lennart/projects/libcanberra/
COMMENT=	Desktop event sound library
LICENSE=	gnu-lgpl-v2.1

USE_LIBTOOL=		yes
USE_TOOLS+=		gmake pkg-config
GNU_CONFIGURE=		yes
CONFIGURE_ENV+=		ac_cv_lib_ltdl_lt_dladvise_init=yes

PKGCONFIG_OVERRIDE+=	libcanberra-gtk.pc.in
PKGCONFIG_OVERRIDE+=	libcanberra-gtk3.pc.in
PKGCONFIG_OVERRIDE+=	libcanberra.pc.in

REPLACE_SH=		src/libcanberra-logout-sound.sh.in

PLIST_VARS+=		oss

.include "options.mk"

.include "../../devel/libltdl/buildlink3.mk"
.include "../../multimedia/gstreamer1/buildlink3.mk"
.include "../../audio/libvorbis/buildlink3.mk"
.include "../../mk/oss.buildlink3.mk"
.if ${OSS_TYPE} != "none"
PLIST.oss=	yes
.endif
.include "../../mk/bsd.pkg.mk"