[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / audio / jack

Annotation of pkgsrc/audio/jack/Makefile, Revision 1.12

1.12    ! bjs         1: # $NetBSD: Makefile,v 1.11 2008/07/31 03:58:05 bjs Exp $
1.1       rillig      2: #
                      3:
1.11      bjs         4: DISTNAME=      jack-audio-connection-kit-${JACK_VERSION}
                      5: PKGNAME=       jack-${JACK_VERSION}
                      6: CATEGORIES=    audio
                      7: MASTER_SITES=  ${MASTER_SITE_LOCAL}
                      8: EXTRACT_SUFX=  .tar.bz2
                      9:
1.12    ! bjs        10: JACK_VERSION=  0.115.1
1.11      bjs        11:
                     12: MAINTAINER=    bjs@NetBSD.org
                     13: HOMEPAGE=      http://www.jackaudio.org/
                     14: COMMENT=       JACK audio connection kit
1.1       rillig     15:
1.11      bjs        16: PKG_DESTDIR_SUPPORT=   user-destdir
                     17:
1.12    ! bjs        18: BUILD_DEFS+=           JACKD_DEFAULT_TMPDIR
        !            19: BUILD_DEFS+=           JACKD_PROCFS_PATH
        !            20:
1.11      bjs        21: GNU_CONFIGURE=         yes
                     22: USE_TOOLS+=            pkg-config
1.2       joerg      23: USE_LIBTOOL=           yes
1.11      bjs        24:
                     25: PKGCONFIG_OVERRIDE+=   jack.pc.in
                     26:
                     27: PTHREAD_OPTS+=         require native
                     28:
                     29: CONFIGURE_ARGS+=       --disable-alsa
                     30: CONFIGURE_ARGS+=       --disable-freebob
                     31: CONFIGURE_ARGS+=       --disable-coreaudio
                     32: CONFIGURE_ARGS+=       --disable-firewire
                     33: CONFIGURE_ARGS+=       --disable-optimize
                     34: CONFIGURE_ARGS+=       --enable-resize
                     35: CONFIGURE_ARGS+=       --enable-timestamps
                     36:
                     37: CFLAGS.NetBSD+=                -D_NETBSD_SOURCE
                     38:
1.4       jlam       39: CONFIGURE_ENV+=                ac_cv_header_readline_chardefs_h=yes
1.1       rillig     40:
1.11      bjs        41: JACKD_DEFAULT_TMPDIR?= /tmp
                     42:
                     43: .include "../../mk/bsd.prefs.mk"
                     44:
1.12    ! bjs        45: .if !empty(OPSYS:M*BSD) || ${OPSYS} == "DragonFly" || ${OPSYS} == "Darwin"
        !            46: CFLAGS+=               -DHOST_HAS_BSD_POLL
        !            47: .endif
        !            48: ###
        !            49: ### XXX Is there a way to properly use the emulation framework
        !            50: ###    for this?
        !            51: ###
        !            52: .if exists(${PREFIX}/emul/linux/proc) && ${OPSYS} != "Linux"
        !            53: JACKD_PROCFS_PATH?=    ${PREFIX}/emul/linux/proc
        !            54: .else
        !            55: JACKD_PROCFS_PATH?=    /proc
1.11      bjs        56: .endif
                     57:
                     58: .if exists(/dev/shm) && ${OPSYS} == "Linux"
                     59: CONFIGURE_ARGS+=       --with-default-tmpdir=/dev/shm
                     60: .else
                     61: CONFIGURE_ARGS+=       --with-default-tmpdir=${JACKD_DEFAULT_TMPDIR:Q}
                     62: .endif
                     63:
1.12    ! bjs        64: PLIST_VARS=            coreaudio oss sunaudio
        !            65: ###
        !            66: ### XXX        This is untested.  Please file a PR and/or commit a fix should
        !            67: ###    any problems arise.
        !            68: ###
        !            69: .if ${OPSYS} == "Darwin"
        !            70: CONFIGURE_ARGS+=       --enable-coreaudio
        !            71: PLIST.coreaudio=       yes
        !            72: .endif
1.11      bjs        73: ###
                     74: ### XXX The sun driver is buggy on NetBSD right now.  I hope to remedy
                     75: ###    this shortly.
                     76: ###
                     77: .if ${OPSYS} == "NetBSD" || ${OPSYS} == "OpenBSD" || ${OPSYS} == "Solaris"
                     78: CONFIGURE_ARGS+=       --enable-sun
                     79: PLIST.sunaudio=                yes
                     80: .else
                     81: CONFIGURE_ARGS+=       --disable-sun
                     82: .endif
                     83:
                     84: .include "../../mk/oss.buildlink3.mk"
1.1       rillig     85:
1.11      bjs        86: .if ${OSS_TYPE} != "none"
                     87: CONFIGURE_ARGS+=       --enable-oss
                     88: PLIST.oss=             yes
                     89: MAKE_ENV+=             LIBOSSAUDIO=${LIBOSSAUDIO:Q}
                     90: CFLAGS+=               -DDEVOSSAUDIO=\"${DEVOSSAUDIO:U/dev/dsp}\"
                     91: .else
                     92: CONFIGURE_ARGS+=       --disable-oss
                     93: .endif
                     94:
1.12    ! bjs        95: SUBST_CLASSES+=                jacksrc
1.11      bjs        96: SUBST_FILES.jacksrc=   libjack/unlock.c
                     97: SUBST_MESSAGE.jacksrc= Peforming substitutions in JACK sources.
                     98: SUBST_STAGE.jacksrc=   pre-build
                     99: SUBST_VARS.jacksrc=    PREFIX JACKD_PROCFS_PATH
                    100:
1.12    ! bjs       101: .if ${MACHINE_ARCH} == "i386" || ${MACHINE_ARCH} == "x86_64"
        !           102: PKG_OPTIONS_VAR=       PKG_OPTIONS.jack
        !           103: PKG_SUPPORTED_OPTIONS= simd
        !           104: PKG_SUGGESTED_OPTIONS= simd
        !           105:
        !           106: .  include "../../mk/bsd.options.mk"
        !           107:
        !           108: .  if !empty(PKG_OPTIONS:Msimd)
        !           109: CONFIGURE_ARGS+=       --enable-simd
        !           110: .  else
        !           111: CONFIGURE_ARGS+=       --disable-simd
        !           112: .  endif
        !           113: .endif
        !           114:
1.11      bjs       115: post-extract:
1.12    ! bjs       116:        ${RUN} ${MKDIR} ${WRKSRC}/config/os/netbsd && \
        !           117:                ${CP} ${FILESDIR}/atomicity.h ${WRKSRC}/config/os/netbsd
1.9       xtraeme   118:
1.11      bjs       119: .include "../../audio/libsamplerate/buildlink3.mk"
1.2       joerg     120: .include "../../devel/readline/buildlink3.mk"
1.11      bjs       121: .include "../../mk/dlopen.buildlink3.mk"
1.2       joerg     122: .include "../../mk/pthread.buildlink3.mk"
1.1       rillig    123: .include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>