[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / audio / gogo

File: [cvs.NetBSD.org] / pkgsrc / audio / gogo / Attic / Makefile (download)

Revision 1.14, Sat Mar 4 21:28:55 2006 UTC (17 years, 9 months ago) by jlam
Branch: MAIN
CVS Tags: pkgsrc-2006Q1-base, pkgsrc-2006Q1
Changes since 1.13: +2 -2 lines

Point MAINTAINER to pkgsrc-users@NetBSD.org in the case where no
developer is officially maintaining the package.

The rationale for changing this from "tech-pkg" to "pkgsrc-users" is
that it implies that any user can try to maintain the package (by
submitting patches to the mailing list).  Since the folks most likely
to care about the package are the folks that want to use it or are
already using it, this would leverage the energy of users who aren't
developers.

# $NetBSD: Makefile,v 1.14 2006/03/04 21:28:55 jlam Exp $
#

DISTNAME=		gogo239b
PKGNAME=		gogo-2.39.1
PKGREVISION=		1
CATEGORIES=		audio
MASTER_SITES=		http://homepage1.nifty.com/herumi/soft/gogo2/src/
EXTRACT_SUFX=		.tgz

MAINTAINER=		pkgsrc-users@NetBSD.org
HOMEPAGE=		http://homepage1.nifty.com/herumi/gogo_e.html
COMMENT=		Very fast lame-based mp3 encoder, i386 only

BUILD_DEPENDS+=		nasm>=0.98:../../devel/nasm

ONLY_FOR_PLATFORM=	*-*-i386

USE_TOOLS+=		gmake

RESTRICTED=		'Source based on patent protected Fraunhofer code'
NO_SRC_ON_FTP=	${RESTRICTED}
NO_SRC_ON_CDROM=	${RESTRICTED}
LICENSE=		fee-based-commercial-use

.include "../../mk/bsd.prefs.mk"

.if (${OBJECT_FMT} == "a.out")
MAKE_FLAGS+=	ASFLAGS="-f aoutb -D__unix__ -DAOUT ${E3DN}"
.else
MAKE_FLAGS+=	ASFLAGS="-f elf -D__unix__ ${E3DN}"
.endif

INSTALLATION_DIRS=	bin

do-install:
	@ ${INSTALL_PROGRAM} ${WRKSRC}/gogo ${PREFIX}/bin
	@ ${INSTALL_DATA_DIR} ${PREFIX}/share/doc/gogo
	@ ${INSTALL_DATA} ${WRKSRC}/readme.txt ${PREFIX}/share/doc/gogo

.include "../../mk/bsd.pkg.mk"