[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / audio / audacious

File: [cvs.NetBSD.org] / pkgsrc / audio / audacious / Makefile (download)

Revision 1.64, Mon May 4 09:37:18 2020 UTC (3 years, 10 months ago) by nia
Branch: MAIN
Changes since 1.63: +2 -2 lines

audacious: Update to 4.0.3

Qt interface fixes/updates:

 * When the menu bar is hidden, an "Audacious" icon is added to the
   toolbar, allowing menu access
 * A-to-B repeat is now available in the Playback menu and displayed in
   the time label
 * The time slider no longer becomes invisible when the window is made
   very small
 * Incorrect behavior of Shift-click selection in the playlist has been
   fixed
 * The checkbox to "Show time scale for current song" in the info popup
   did nothing and has been removed

Other fixes/updates:

 * A rare crash/freeze caused by a race condition in the ALSA output
   plugin has been fixed
 * The EQ preset button in the Qt Winamp Classic interface now works
 * The Qt Winamp Classic interface now has an option to stay on top of
   other windows
 * The Song Info plugin now updates correctly when the title changes or
   playback stops

Other changes:

 * Due to frequent crashes, the Stream Tuner plugin is now disabled by
   default
 * Translations have been updated

# $NetBSD: Makefile,v 1.64 2020/05/04 09:37:18 nia Exp $

DISTNAME=	audacious-4.0.3
CATEGORIES=	audio
MASTER_SITES=	https://distfiles.audacious-media-player.org/
EXTRACT_SUFX=	.tar.bz2

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	https://audacious-media-player.org/
COMMENT=	Media player based on BMP and XMMS
LICENSE=	2-clause-bsd

USE_LANGUAGES=		c c++
USE_TOOLS+=		gmake pkg-config
USE_TOOLS+=		intltool msgfmt msgmerge xgettext
GNU_CONFIGURE=		yes
PKGCONFIG_OVERRIDE+=	audacious.pc.in

# XXX does not solve linking problem completely
LDFLAGS.Darwin+=	-flat_namespace -undefined suppress

.include "options.mk"
.include "../../devel/gettext-lib/buildlink3.mk"
.include "../../devel/glib2/buildlink3.mk"
.include "../../graphics/hicolor-icon-theme/buildlink3.mk"
.include "../../sysutils/desktop-file-utils/desktopdb.mk"
.include "../../x11/qt5-qtbase/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"