[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / audio / audacious-plugins

File: [cvs.NetBSD.org] / pkgsrc / audio / audacious-plugins / Makefile (download)

Revision 1.42, Mon Jun 3 10:04:31 2013 UTC (10 years, 10 months ago) by wiz
Branch: MAIN
Changes since 1.41: +2 -2 lines

Bump freetype2 and fontconfig dependencies to current pkgsrc versions,
to address issues with NetBSD-6(and earlier)'s fontconfig not being
new enough for pango.

While doing that, also bump freetype2 dependency to current pkgsrc
version.

Suggested by tron in PR 47882

# $NetBSD: Makefile,v 1.42 2013/06/03 10:04:31 wiz Exp $
#

DISTNAME=		audacious-plugins-1.5.1
PKGREVISION=		33
CATEGORIES=		audio
MASTER_SITES=		http://distfiles.atheme.org/
EXTRACT_SUFX=		.tgz

MAINTAINER=		jfranz@bsdprojects.net
HOMEPAGE=		http://audacious-media-player.org/
COMMENT=		Plugins for Audacious media player

GNU_CONFIGURE=		yes
USE_TOOLS+=		gmake intltool pkg-config msgfmt
USE_LIBTOOL=		yes

# This should avoid an error like: libstdc++.so.6: Undefined PLT symbol "_Unwind_GetIP" on NetBSD i386 and maybe amd64, with gcc4 at least.
# This seems to happen when libstdc++ gets linked in with the plug-ins and the code is not compiled with g++.
# For a similar problem see http://archive.netbsd.se/?ml=netbsd-java&a=2007-08&m=4912662 :
LDFLAGS.NetBSD+=	-lgcc_s

# From audio/bmp/Makefile:
# XXX Workaround a crash during shutdown that happens when dlclose(3)ing
# any open plugin.  libstdc++ gets dynamically linked in when the id3lib
# library is loaded, and is the one causing problems.  See PR pkg/26846
# for more information.
USE_LANGUAGES=		c c++
LDFLAGS.NetBSD+=	-lstdc++ -lm

# cdaudio plugin complains about missing OSS at runtime
LDFLAGS+=		${LIBOSSAUDIO}

# do not use pkgsrc' flac if it is installed
CFLAGS+=	-I. -I../flacng -Ilibflacng

CONFIGURE_ARGS+=	--disable-amidiplug --disable-evdevplug \
			--disable-coreaudio --disable-projectm \
			--disable-gnomeshortcuts

.include "../../mk/bsd.prefs.mk"
.include "options.mk"

PLIST_VARS+=	oss sun oss4

.if ${OPSYS} == "NetBSD"
RAWPART_cmd=		/sbin/sysctl -n kern.rawpartition | ${TR} 0-9 a-j
CONFIGURE_ARGS+=	--with-dev-dsp=${DEVOSSSOUND}			\
			--with-cdda-device=/dev/rcd0${RAWPART_cmd:sh}	\
			--with-cdda-dir=/cdrom/
PLIST.oss=	yes
PLIST.sun=	yes
.elif ${OPSYS} == "FreeBSD"
PLIST.oss=	yes
.elif ${OPSYS} == "DragonFly"
PLIST.oss=	yes
.elif ${OPSYS} == "SunOS"
BUILDLINK_TRANSFORM+=	rm:-Wl,-export-dynamic
CPPFLAGS.SunOS=	-D__EXTENSIONS__ -D__uint32_t=uint32_t -D__uint64_t=uint64_t
CONFIGURE_ARGS+=	--enable-oss4
PLIST.oss4=	yes
PLIST.oss=	yes
#.elif ${OPSYS} == "Linux"
#.  include	"../../wip/alsa-lib/buildlink3.mk"
#PKG_SUPPORTED_OPTIONS+= lirc
#.  if !empty(PKG_OPTIONS:Mlirc)
#CONFIGURE_ARGS+=	--enable-lirc
#.    include "../../wip/lirc/buildlink3.mk"
#.  endif
.endif

.include "../../audio/audacious/buildlink3.mk"
.include "../../audio/libcddb/buildlink3.mk"
.include "../../audio/libmad/buildlink3.mk"
.include "../../audio/libmpcdec/buildlink3.mk"
.include "../../audio/libvorbis/buildlink3.mk"
.include "../../audio/libsndfile/buildlink3.mk"
.include "../../audio/taglib/buildlink3.mk"
.include "../../audio/wavpack/buildlink3.mk"
.include "../../audio/lame/buildlink3.mk"
.include "../../devel/libbinio/buildlink3.mk"
.include "../../devel/libmtp/buildlink3.mk"
.include "../../devel/SDL/buildlink3.mk"
.include "../../graphics/imlib2/buildlink3.mk"
.include "../../misc/libcdio/buildlink3.mk"
.include "../../multimedia/libogg/buildlink3.mk"
.include "../../net/libmms/buildlink3.mk"
.include "../../www/curl/buildlink3.mk"
.include "../../www/neon/buildlink3.mk"
.include "../../x11/libXcomposite/buildlink3.mk"
.include "../../mk/oss.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"