[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / audio / audacious-plugins

File: [cvs.NetBSD.org] / pkgsrc / audio / audacious-plugins / Makefile (download)

Revision 1.3, Mon Nov 10 12:06:06 2008 UTC (15 years, 5 months ago) by wiz
Branch: MAIN
Changes since 1.2: +2 -2 lines

Update to 1.5.1:

Audacious-plugins 1.5.1 (2008-05-23)
====================================

Enhancements
------------
* Some ModPlug playback engine fixes integrated from Schism Tracker.
* ModPlug archive support "works" now again, but only on local files.
* cdaudio-ng now has a rescan option.
* Various enhancements in Audacious-SID plugin synchronized from
  XMMS-SID.

Bugfixes
--------
* ModPlug starting to play from incorrect pattern order was fixed.
* Some unaligned access and other nasty bugs fixed in MADPlug.
* Code cleanups made in various plugins (not nearly enough, though.)
* Cleaned up and refactored configure and various buildsystem fixes.
* ProjectM compatibility fixes.
* demac plugin skips leading junk in APE files.
* Some sndfile plugin problems, including a filehandle leak, were fixed.
* Several crash fixes in the Neon HTTP/HTTPS transport plugin.

# $NetBSD: Makefile,v 1.3 2008/11/10 12:06:06 wiz Exp $
#

DISTNAME=		audacious-plugins-1.5.1
CATEGORIES=		audio
MASTER_SITES=		http://distfiles.atheme.org/
EXTRACT_SUFX=		.tgz

MAINTAINER=		jfranz@bsdprojects.net
HOMEPAGE=		http://audacious-media-player.org/
COMMENT=		Plugins for Audacious media player

GNU_CONFIGURE=		yes
USE_TOOLS+=		gmake intltool pkg-config
USE_LIBTOOL=		yes

# This should avoid an error like: libstdc++.so.6: Undefined PLT symbol "_Unwind_GetIP" on NetBSD i386 and maybe amd64, with gcc4 at least.
# This seems to happen when libstdc++ gets linked in with the plug-ins and the code is not compiled with g++.
# For a similar problem see http://archive.netbsd.se/?ml=netbsd-java&a=2007-08&m=4912662 :
LDFLAGS.NetBSD+=	-lgcc_s

# From audio/bmp/Makefile:
# XXX Workaround a crash during shutdown that happens when dlclose(3)ing
# any open plugin.  libstdc++ gets dynamically linked in when the id3lib
# library is loaded, and is the one causing problems.  See PR pkg/26846
# for more information.
USE_LANGUAGES=		c c++
LDFLAGS.NetBSD+=	-lstdc++ -lm

# cdaudio plugin complains about missing OSS at runtime
LDFLAGS+=		${LIBOSSAUDIO}

# do not use pkgsrc' flac if it is installed
CFLAGS+=	-I. -I../flacng -Ilibflacng

CONFIGURE_ARGS+=	--disable-amidiplug --disable-evdevplug \
			--disable-coreaudio --disable-projectm \
			--disable-gnomeshortcuts

.include "../../mk/bsd.prefs.mk"
.include "options.mk"

PLIST_VARS+=	oss sun

.if ${OPSYS} == "NetBSD"
RAWPART_cmd=		/sbin/sysctl -n kern.rawpartition | ${TR} 0-9 a-j
CONFIGURE_ARGS+=	--with-dev-dsp=${DEVOSSSOUND}			\
			--with-cdda-device=/dev/rcd0${RAWPART_cmd:sh}	\
			--with-cdda-dir=/cdrom/
PLIST.oss=	yes
PLIST.sun=	yes
.elif ${OPSYS} == "FreeBSD"
PLIST.oss=	yes
.elif ${OPSYS} == "DragonFly"
PLIST.oss=	yes
.elif ${OPSYS} == "SunOS"
PLIST.sun=	yes
#.elif ${OPSYS} == "Linux"
#.  include	"../../wip/alsa-lib/buildlink3.mk"
#PKG_SUPPORTED_OPTIONS+= lirc
#.  if !empty(PKG_OPTIONS:Mlirc)
#CONFIGURE_ARGS+=	--enable-lirc
#.    include "../../wip/lirc/buildlink3.mk"
#.  endif
.endif

.include "../../audio/audacious/buildlink3.mk"
.include "../../audio/libcddb/buildlink3.mk"
.include "../../audio/libmad/buildlink3.mk"
.include "../../audio/libmpcdec/buildlink3.mk"
.include "../../audio/libvorbis/buildlink3.mk"
.include "../../audio/libsndfile/buildlink3.mk"
.include "../../audio/taglib/buildlink3.mk"
.include "../../audio/wavpack/buildlink3.mk"
.include "../../audio/lame/buildlink3.mk"
.include "../../devel/libbinio/buildlink3.mk"
.include "../../devel/libmtp/buildlink3.mk"
.include "../../devel/SDL/buildlink3.mk"
.include "../../graphics/imlib2/buildlink3.mk"
.include "../../misc/libcdio/buildlink3.mk"
.include "../../multimedia/libogg/buildlink3.mk"
.include "../../net/libmms/buildlink3.mk"
.include "../../www/curl/buildlink3.mk"
.include "../../www/neon/buildlink3.mk"
.include "../../x11/libXcomposite/buildlink3.mk"
.include "../../mk/oss.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"