[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / audio / audacious-plugins

Annotation of pkgsrc/audio/audacious-plugins/Makefile, Revision 1.55

1.55    ! ryoon       1: # $NetBSD: Makefile,v 1.54 2014/04/18 15:38:36 wiz Exp $
1.1       wiz         2:
1.3       wiz         3: DISTNAME=              audacious-plugins-1.5.1
1.55    ! ryoon       4: PKGREVISION=           44
1.1       wiz         5: CATEGORIES=            audio
                      6: MASTER_SITES=          http://distfiles.atheme.org/
                      7: EXTRACT_SUFX=          .tgz
                      8:
                      9: MAINTAINER=            jfranz@bsdprojects.net
                     10: HOMEPAGE=              http://audacious-media-player.org/
                     11: COMMENT=               Plugins for Audacious media player
                     12:
                     13: GNU_CONFIGURE=         yes
1.4       hasso      14: USE_TOOLS+=            gmake intltool pkg-config msgfmt
1.1       wiz        15: USE_LIBTOOL=           yes
1.50      joerg      16: USE_LANGUAGES=         c c++
1.1       wiz        17:
1.50      joerg      18: .include "../../mk/compiler.mk"
                     19: .if empty(PKGSRC_COMPILER:Mclang)
1.1       wiz        20: # This should avoid an error like: libstdc++.so.6: Undefined PLT symbol "_Unwind_GetIP" on NetBSD i386 and maybe amd64, with gcc4 at least.
                     21: # This seems to happen when libstdc++ gets linked in with the plug-ins and the code is not compiled with g++.
                     22: # For a similar problem see http://archive.netbsd.se/?ml=netbsd-java&a=2007-08&m=4912662 :
1.50      joerg      23: # Systems with Clang are supposed to be new enough to have a correctly linked
                     24: # libstdc++.
1.1       wiz        25: LDFLAGS.NetBSD+=       -lgcc_s
1.50      joerg      26: .endif
1.1       wiz        27:
                     28: # From audio/bmp/Makefile:
                     29: # XXX Workaround a crash during shutdown that happens when dlclose(3)ing
                     30: # any open plugin.  libstdc++ gets dynamically linked in when the id3lib
                     31: # library is loaded, and is the one causing problems.  See PR pkg/26846
                     32: # for more information.
                     33: LDFLAGS.NetBSD+=       -lstdc++ -lm
                     34:
                     35: # cdaudio plugin complains about missing OSS at runtime
                     36: LDFLAGS+=              ${LIBOSSAUDIO}
                     37:
                     38: # do not use pkgsrc' flac if it is installed
                     39: CFLAGS+=       -I. -I../flacng -Ilibflacng
                     40:
1.54      wiz        41: CONFIGURE_ARGS+=       --disable-amidiplug
                     42: CONFIGURE_ARGS+=       --disable-evdevplug
                     43: CONFIGURE_ARGS+=       --disable-coreaudio
                     44: CONFIGURE_ARGS+=       --disable-projectm
                     45: CONFIGURE_ARGS+=       --disable-gnomeshortcuts
                     46: CONFIGURE_ARGS+=       --disable-modplug
1.1       wiz        47:
                     48: .include "../../mk/bsd.prefs.mk"
                     49: .include "options.mk"
                     50:
1.19      hans       51: PLIST_VARS+=   oss sun oss4
1.2       wiz        52:
1.1       wiz        53: .if ${OPSYS} == "NetBSD"
                     54: RAWPART_cmd=           /sbin/sysctl -n kern.rawpartition | ${TR} 0-9 a-j
                     55: CONFIGURE_ARGS+=       --with-dev-dsp=${DEVOSSSOUND}                   \
                     56:                        --with-cdda-device=/dev/rcd0${RAWPART_cmd:sh}   \
                     57:                        --with-cdda-dir=/cdrom/
1.2       wiz        58: PLIST.oss=     yes
                     59: PLIST.sun=     yes
1.1       wiz        60: .elif ${OPSYS} == "FreeBSD"
1.2       wiz        61: PLIST.oss=     yes
1.1       wiz        62: .elif ${OPSYS} == "DragonFly"
1.2       wiz        63: PLIST.oss=     yes
1.1       wiz        64: .elif ${OPSYS} == "SunOS"
1.18      hans       65: CPPFLAGS.SunOS=        -D__EXTENSIONS__ -D__uint32_t=uint32_t -D__uint64_t=uint64_t
1.19      hans       66: CONFIGURE_ARGS+=       --enable-oss4
                     67: PLIST.oss4=    yes
1.18      hans       68: PLIST.oss=     yes
1.1       wiz        69: #.elif ${OPSYS} == "Linux"
                     70: #.  include    "../../wip/alsa-lib/buildlink3.mk"
                     71: #PKG_SUPPORTED_OPTIONS+= lirc
                     72: #.  if !empty(PKG_OPTIONS:Mlirc)
                     73: #CONFIGURE_ARGS+=      --enable-lirc
                     74: #.    include "../../wip/lirc/buildlink3.mk"
                     75: #.  endif
                     76: .endif
                     77:
                     78: .include "../../audio/audacious/buildlink3.mk"
                     79: .include "../../audio/libcddb/buildlink3.mk"
                     80: .include "../../audio/libmad/buildlink3.mk"
                     81: .include "../../audio/libmpcdec/buildlink3.mk"
1.54      wiz        82: .include "../../audio/libsndfile/buildlink3.mk"
1.1       wiz        83: .include "../../audio/libvorbis/buildlink3.mk"
                     84: .include "../../audio/taglib/buildlink3.mk"
                     85: .include "../../audio/wavpack/buildlink3.mk"
                     86: .include "../../audio/lame/buildlink3.mk"
                     87: .include "../../devel/libbinio/buildlink3.mk"
                     88: .include "../../devel/libmtp/buildlink3.mk"
                     89: .include "../../devel/SDL/buildlink3.mk"
                     90: .include "../../graphics/imlib2/buildlink3.mk"
                     91: .include "../../misc/libcdio/buildlink3.mk"
                     92: .include "../../multimedia/libogg/buildlink3.mk"
                     93: .include "../../net/libmms/buildlink3.mk"
                     94: .include "../../www/curl/buildlink3.mk"
                     95: .include "../../www/neon/buildlink3.mk"
                     96: .include "../../x11/libXcomposite/buildlink3.mk"
                     97: .include "../../mk/oss.buildlink3.mk"
                     98: .include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>