[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / audio / audacious-plugins

Annotation of pkgsrc/audio/audacious-plugins/Makefile, Revision 1.1.1.1

1.1       wiz         1: # $NetBSD$
                      2: #
                      3:
                      4: DISTNAME=              audacious-plugins-1.5.0
                      5: CATEGORIES=            audio
                      6: MASTER_SITES=          http://distfiles.atheme.org/
                      7: EXTRACT_SUFX=          .tgz
                      8:
                      9: MAINTAINER=            jfranz@bsdprojects.net
                     10: HOMEPAGE=              http://audacious-media-player.org/
                     11: COMMENT=               Plugins for Audacious media player
                     12:
                     13: GNU_CONFIGURE=         yes
                     14: USE_TOOLS+=            gmake intltool pkg-config
                     15: USE_LIBTOOL=           yes
                     16:
                     17: # This should avoid an error like: libstdc++.so.6: Undefined PLT symbol "_Unwind_GetIP" on NetBSD i386 and maybe amd64, with gcc4 at least.
                     18: # This seems to happen when libstdc++ gets linked in with the plug-ins and the code is not compiled with g++.
                     19: # For a similar problem see http://archive.netbsd.se/?ml=netbsd-java&a=2007-08&m=4912662 :
                     20: LDFLAGS.NetBSD+=       -lgcc_s
                     21:
                     22: # From audio/bmp/Makefile:
                     23: # XXX Workaround a crash during shutdown that happens when dlclose(3)ing
                     24: # any open plugin.  libstdc++ gets dynamically linked in when the id3lib
                     25: # library is loaded, and is the one causing problems.  See PR pkg/26846
                     26: # for more information.
                     27: USE_LANGUAGES=         c c++
                     28: LDFLAGS.NetBSD+=       -lstdc++ -lm
                     29:
                     30: # cdaudio plugin complains about missing OSS at runtime
                     31: LDFLAGS+=              ${LIBOSSAUDIO}
                     32:
                     33: # do not use pkgsrc' flac if it is installed
                     34: CFLAGS+=       -I. -I../flacng -Ilibflacng
                     35:
                     36: CONFIGURE_ARGS+=       --disable-amidiplug --disable-evdevplug \
                     37:                        --disable-coreaudio --disable-projectm \
                     38:                        --disable-gnomeshortcuts
                     39:
                     40: .include "../../mk/bsd.prefs.mk"
                     41: .include "options.mk"
                     42:
                     43: .if ${OPSYS} == "NetBSD"
                     44: RAWPART_cmd=           /sbin/sysctl -n kern.rawpartition | ${TR} 0-9 a-j
                     45: CONFIGURE_ARGS+=       --with-dev-dsp=${DEVOSSSOUND}                   \
                     46:                        --with-cdda-device=/dev/rcd0${RAWPART_cmd:sh}   \
                     47:                        --with-cdda-dir=/cdrom/
                     48: PLIST_SUBST+=          OSS=""
                     49: PLIST_SUBST+=          SUN=""
                     50: .elif ${OPSYS} == "FreeBSD"
                     51: PLIST_SUBST+=          OSS=""
                     52: PLIST_SUBST+=          SUN="@comment "
                     53: .elif ${OPSYS} == "DragonFly"
                     54: PLIST_SUBST+=          OSS=""
                     55: PLIST_SUBST+=          SUN="@comment "
                     56: .elif ${OPSYS} == "SunOS"
                     57: PLIST_SUBST+=          OSS="@comment "
                     58: PLIST_SUBST+=          SUN=""
                     59: #.elif ${OPSYS} == "Linux"
                     60: #.  include    "../../wip/alsa-lib/buildlink3.mk"
                     61: #PKG_SUPPORTED_OPTIONS+= lirc
                     62: #.  if !empty(PKG_OPTIONS:Mlirc)
                     63: #CONFIGURE_ARGS+=      --enable-lirc
                     64: #.    include "../../wip/lirc/buildlink3.mk"
                     65: #.  endif
                     66: .endif
                     67:
                     68: .include "../../audio/audacious/buildlink3.mk"
                     69: .include "../../audio/libcddb/buildlink3.mk"
                     70: .include "../../audio/libmad/buildlink3.mk"
                     71: .include "../../audio/libmpcdec/buildlink3.mk"
                     72: .include "../../audio/libvorbis/buildlink3.mk"
                     73: .include "../../audio/libsndfile/buildlink3.mk"
                     74: .include "../../audio/taglib/buildlink3.mk"
                     75: .include "../../audio/wavpack/buildlink3.mk"
                     76: .include "../../audio/lame/buildlink3.mk"
                     77: .include "../../devel/libbinio/buildlink3.mk"
                     78: .include "../../devel/libmtp/buildlink3.mk"
                     79: .include "../../devel/SDL/buildlink3.mk"
                     80: .include "../../graphics/imlib2/buildlink3.mk"
                     81: .include "../../misc/libcdio/buildlink3.mk"
                     82: .include "../../multimedia/libogg/buildlink3.mk"
                     83: .include "../../net/libmms/buildlink3.mk"
                     84: .include "../../www/curl/buildlink3.mk"
                     85: .include "../../www/neon/buildlink3.mk"
                     86: .include "../../x11/libXcomposite/buildlink3.mk"
                     87: .include "../../mk/oss.buildlink3.mk"
                     88: .include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>