[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / audio / amarok

File: [cvs.NetBSD.org] / pkgsrc / audio / amarok / Attic / Makefile (download)

Revision 1.59, Sun Jul 1 00:33:52 2007 UTC (16 years, 9 months ago) by wiz
Branch: MAIN
Changes since 1.58: +4 -4 lines

Update to 1.4.6:

VERSION 1.4.6
  CHANGES:
    * Improved icon theme, kindly provided by Landy DeField
      <lando@revelinux.com>. Big thanks!
    * Playlist now sends notifications to scripts if items are added, removed,
      reordered, or if the playlist is cleared.  Useful for script authors.
      Thanks to Miguel Angel Alvarez <maacruz@gmail.com> for the patch.
    * iPod device plugin now handles RockBox devices.  Thanks to Michael
      Buesch <mb@bu3sch.de> for the patch.
    * Organising files will only delete empty parent folders if the folder
      is within the collection hierarchy. (BR 136757)
    * The default cover image preview size has been increased to 130px.
    * The "hide menubar" option has been removed. It's too dangerous and led
      to countless support requests.
    * Generic media device can now handle any KIO-compatible URL, including
      obex and smb. Manage your bluetooth phone's music collection through
      Amarok!
    * Upgraded SQLite to 3.3.17.
    * Append an album to the playlist by right-clicking on it from within
      the Cover Manager.  Patch by Doug Reich <dreich@hmc.edu>.
    * Faster playlist handling. Patch by Ovy <ovy@alum.mit.edu>. (BR 142255)
    * The moodbar process has been given a higher priority. (BR 136867)
    * Allow for lyrics scripts to specifiy site, site_url, and add_url from
      within the script. This will allow for "meta lyrics" scripts. Patch by
      Sergio Pistone <sergio_pistone@yahoo.com.ar>. (BR 141885)
    * First rating star now lets you toggle between no rating, half a star,
      and one full star.

  BUGFIXES:
    * Uninstalling scripts would in some cases leave files behind. Patch by
      Sergio Pistone <sergio_pistone@yahoo.com.ar>. (BR 143716)
    * Last.fm "Custom Station" stream works again. (BR 146020)
    * Fix regression where the "Show Script Manager" button displayed on the
      Lyrics tab of the Context Browser wouldn't actually show the Script
      Manager.
    * Don't show ratings from the previous track's rating change in the OSD on
      playing the next track.
    * The config dialog is now less tall and fits on widescreen displays.
    * Making a dynamic playlist with the number of previously played tracks to
      show set to zero and attempting to play the first track would cause a
      crash. (BR 145157)
    * If "Stop after current track" was used, the last track would not be
      counted or rated in the user's statistics. (BR 140980)
    * Generic media device wouldn't allow you to drop a folder on the
      viewport, meaning you couldn't move subfolders to the top level of the
      mount point.
    * Made the settings dialog less tall. (BR 141250)
    * Star ratings now update instantly in the Context Browser, OSD, and
      Collection Browser.
    * lyrc script did not work behind proxy due to a stray quote mark. Gentoo
      Bug 166050.
    * Fix compilation on kde-3.3 systems.
    * amarok_live.py now uses popen correctly. Patch by Luke Macken
      <lmacken@fedoraproject.org>. (BR 127804)
    * Make amarok_proxy.rb use HTTP/1.0 as we don't support chunked responses.
      Patch by solsTiCE <solstice.dhiver@laposte.net>. (BR 141819)
    * Fix Quadratic loading in Playlists. Patch by Ovy
      <ovy@alum.mit.edu>. (BR 142255)
    * Correctly set iPod model. Patch by İsmail Dönmez <ismail@kde.org>.
    * Fix detection of vfat devices on FreeBSD. (BR 141614)
    * Right-click on volume slider would change the volume. (BR 141672)

# $NetBSD: Makefile,v 1.59 2007/07/01 00:33:52 wiz Exp $

DISTNAME=		amarok-${VERSION}
VERSION=		1.4.6
CATEGORIES=		audio kde
MASTER_SITES=		${MASTER_SITE_KDE:=amarok/${VERSION}/src/}
EXTRACT_SUFX=		.tar.bz2

MAINTAINER=		wiz@NetBSD.org
HOMEPAGE=		http://amarok.kde.org/
COMMENT=		KDE audio player

DEPENDS+=		unzip-[0-9]*:../../archivers/unzip

USE_DIRS+=		xdg-1.1
USE_TOOLS+=		gmake pkg-config msgfmt
USE_LANGUAGES=		c c++
GNU_CONFIGURE=		yes
USE_LIBTOOL=		yes

CONFIGURE_ARGS+=	--without-nmm
CONFIGURE_ARGS+=	--without-mas
CONFIGURE_ARGS+=	--without-helix
CONFIGURE_ARGS+=	--with-mp4v2
CONFIGURE_ARGS+=	--with-mp4v2-dir=${LOCALBASE}

LIBS+=			${LIBOSSAUDIO}

PYTHON_PATCH_SCRIPTS= \
	amarok/src/scripts/common/Publisher.py \
	amarok/src/scripts/common/Zeroconf.py \
	amarok/src/scripts/playlist2html/Playlist.py \
	amarok/src/scripts/webcontrol/Playlist.py \
	amarok/src/scripts/playlist2html/PlaylistServer.py \
	amarok/src/scripts/playlist2html/playlist2html.py \
	amarok/src/scripts/templates/python_qt_template.py \
	amarok/src/scripts/webcontrol/Globals.py \
	amarok/src/scripts/playlist2html/Playlist.py \
	amarok/src/scripts/webcontrol/Playlist.py \
	amarok/src/scripts/webcontrol/RequestHandler.py \
	amarok/src/scripts/webcontrol/WebControl.py \
	amarok/src/scripts/webcontrol/WebPublisher.py
REPLACE_RUBY= \
	amarok/src/amarok_proxy.rb \
	amarok/src/mediadevice/daap/amarok_daapserver.rb \
	amarok/src/scripts/lyrics_astraweb/lyrics_astraweb.rb \
	amarok/src/scripts/lyrics_lyrc/lyrics_lyrc.rb \
	amarok/src/scripts/ruby_debug/debug.rb \
	amarok/src/scripts/score_default/score_default.rb \
	amarok/src/scripts/score_impulsive/score_impulsive.rb \
	amarok/src/scripts/templates/amarok.rb \
	amarok/src/scripts/templates/ruby_qt_template.rb

SUBST_CLASSES+=		dotkdedir
SUBST_STAGE.dotkdedir=	post-patch
SUBST_MESSAGE.dotkdedir=Replacing .kde/share with .kde/share/kde
SUBST_FILES.dotkdedir= \
	amarok/src/scripts/playlist2html/Playlist.py \
	amarok/src/scripts/webcontrol/Playlist.py \
	doc/*/config.docbook doc/*/faq.docbook doc/*/advanced.docbook
SUBST_SED.dotkdedir=	-e 's,\.kde/share/,.kde/share/kde/,'

BUILDLINK_API_DEPENDS.kdebase+=	kdebase>=3.3.0
BUILDLINK_API_DEPENDS.kdelibs+=	kdelibs>=3.3.0
BUILDLINK_API_DEPENDS.taglib+=	taglib>=1.4

.include "options.mk"

.include "../../audio/libtunepimp/buildlink3.mk"
.include "../../audio/libvisual/buildlink3.mk"
.include "../../devel/SDL/buildlink3.mk"
.include "../../audio/taglib/buildlink3.mk"
.include "../../graphics/hicolor-icon-theme/buildlink3.mk"
.include "../../lang/python/application.mk"
.include "../../lang/ruby/buildlink3.mk"
.include "../../lang/ruby/replace.mk"
.include "../../meta-pkgs/kde3/kde3.mk"
.include "../../mk/oss.buildlink3.mk"
.include "../../multimedia/kdemultimedia3/buildlink3.mk"
.include "../../multimedia/libmp4v2/buildlink3.mk"
.include "../../multimedia/xine-lib/buildlink3.mk"
.include "../../x11/kdebase3/buildlink3.mk"
.include "../../x11/kdelibs3/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"