[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / audio / amarok

File: [cvs.NetBSD.org] / pkgsrc / audio / amarok / Attic / Makefile (download)

Revision 1.13, Wed Sep 7 11:29:41 2005 UTC (18 years, 7 months ago) by seb
Branch: MAIN
CVS Tags: pkgsrc-2005Q3-base, pkgsrc-2005Q3
Changes since 1.12: +2 -2 lines

Update to version 1.3.1 'Airborne'.

Changes since last packaged version (1.3):

VERSION 1.3.1:
  FEATURES:
    * Added 'Set as Playlist (Crop)' and 'Save as Playlist' options in the
      playlist context menu. (BR 99932)
    * Support for iPod shuffle devices. Patch by Guenter Schwann
      <harry.w@gmx.at>.
    * Media Device browser now has a connect button for connecting
      your iPod after amaroK has already been started. Also includes
      configurable mounting/unmounting options.
    * Holding down the stop button (as opposed to just clicking it) pops
      up a menu letting you stop either now, after the current track, or
      after the end of the queue.
    * Collection browser filter now fully supports the same Google-esque
      syntax as the playlist filter, plus one extra: lyrics:"stuff to search
      for" to search in cached lyrics.
    * Pressing Shift+Enter after filtering the playlist will now queue
      the first track. (BR 111054)
    * Display short statistics in the collection browser depending on the
      categorisation method.
    * New DCOP call "collection: totalTracks". Returns the total number of
      tracks in the collection.
    * New DCOP call "collection: totalGenres". Returns the total number of
      genres in the collection.
    * New DCOP call "collection: totalCompilations". Returns the total number
      of compilations in the collection.
    * New DCOP call "collection: totalArtists". Returns the total number of
      artists in the collection.
    * New DCOP call "collection: totalAlbums". Returns the total number of
      tracks in the collection.
    * New DCOP call "collection: similarArtists(int artists)". Returns the
      similar artists of the current track, results are limited by 'artists'.
    * New DCOP call "playlist: repopulate". Repopulates the playlist with
      tracks from dynamic mode.
    * New DCOP call "player: showBrowser". Allows for showing of playlist
      window browser, see the handbook for useage.
    * New DCOP call "player: setLyricsByPath". Allows adding custom lyrics
      for tracks.
    * Add an icon in the statusbar displaying the number of queued tracks;
      click on it to pop up a menu letting you jump to their locations in
      the playlist.

  CHANGES:
    * New "Blue Danna" splash screen. Created by Nenad Grujicic, modified by
      Nathan Adolph.
    * 'Stop after track' is now saved (and so remembered across amaroK
      restarts).
    * Ported playlist + filter-lineedit behaviour to collection browser as
      well: you can move between the view and the filter with the up/down
      buttons, and just typing into the view will set the filter. (BR 108656)
    * Wiki Tab links use the color set for links, instead of "Selected
      Background". Style Authors can use "AMAROK_LINKCOLOR" if they want that
      color. (BR 111228)
    * The Equalizer widget has been pimped.
    * Pressing 'up' in the playlist filter will now take you to the end of
      the playlist, in addition to down going to the beginning, as before.
    * When jumping to the current track, it now gets centered instead of only
      barely showing.
    * GStreamer-engine was rewritten. The crossfading feature was removed for
      now (it didn't work right with recent GStreamer versions). Improvements:
      1) Reduced CPU usage 2) Reduced latency 3) Increased stability
    * No need to restart amaroK to use your iPod!
    * Improved Konqueror Sidebar.
    * The bundled "Shouter" AmarokScript (for radio stream serving) has been
      updated and improved.

  BUGFIXES:
    * amaroK wouldn't remember current track when restarting. (BR 110282)
    * Some memory leaks found and fixed.
    * Fix buzz and subsequent clicking when equalizer enabled in Helix and
      GStreamer engines compiled with GCC 4.0.1.
    * Burn option wouldn't show up for "Year - Album" items on Collection
      Browser.
    * Tray's tooltip would show things like 69:40 of 1:12:01.
    * Wiki Tab wouldn't work for names that contained "/". (BR 111634)
    * With KDE 3.4, the proper context menu wouldn't be shown for File
      Browser. Patch by Christian Baumgart <christianbaumgart@web.de>.
      (BR 103305)
    * Playcounter and Access Date wouldn't be updated properly for PostgreSQL.
      Patch by Tonton <tonton-lists@team1664.org>. (BR 111519)
    * Clicking twice on the uninstall button for the same script, would make
      amaroK crash.
    * Fixed an obscure crash when you emptied the playlist, had the focus on
      it, and pressed up.
    * No longer show dynamic info popup on application startup.  Patch by
      Christian Baumgart <christianbaumgart@web.de>.
    * Sometimes the system tray tooltip did not update on song change.
    * Polishing for the collection browser and expanded item states. Patch
      by Christian Baumgart <christianbaumgart@web.de>.
    * With xine-engine amaroK always treated remote media like radio streams.
    * Selecting Classical equalizer preset prompted for name.
    * Fixed konqueror sidebar compilation with kde <= 3.3 and gcc patched for
      visibility.
    * Konqueror sidebar can switch again between tabs.
    * Fixed playing of oggs in helix engine.
    * Fixed crash in helix engine when switching engines if helix/realplayer
      not installed.
    * Undo/Redo for the playlist was broken in some cases.
    * On Collection Browser, when grouping by Genre/Artist/Year-Album it
      wouldn't show the tracks. (BR 110890)
    * SmartPlaylist Editor would reset "Match Any" to "Match All" when
      editing. Patch by Kevin Henderson <pyspud@hotmail.com> (BR 110918).
    * Podcasts and playlist tracks would be sorted lexicographically
      (BR 97297).
    * Saved dynamic playlists were not removable.
    * xine-engine: amaroK would get stuck on exit if the Equalizer was enabled
      and the engine playing. (BR 110791)
    * Dequeued items sometimes weren't being repainted properly.

# $NetBSD: Makefile,v 1.13 2005/09/07 11:29:41 seb Exp $

DISTNAME=		amarok-1.3.1
CATEGORIES=		audio kde
MASTER_SITES=		${MASTER_SITE_SOURCEFORGE:=amarok/}
EXTRACT_SUFX=		.tar.bz2

MAINTAINER=		seb@NetBSD.org
HOMEPAGE=		http://amarok.kde.org/
COMMENT=		KDE audio player

USE_DIRS+=		xdg-1.1
USE_TOOLS+=		gmake pkg-config
USE_LANGUAGES=		c c++
GNU_CONFIGURE=		yes

CONFIGURE_ARGS+=	--without-nmm
CONFIGURE_ARGS+=	--without-mas

LIBS+=			${LIBOSSAUDIO}

BUILDLINK_DEPENDS.gst-plugins+=	gst-plugins>=0.8.6
BUILDLINK_DEPENDS.gstreamer+=	gstreamer>=0.8.6
BUILDLINK_DEPENDS.kdebase+=	kdebase>=3.3.0
BUILDLINK_DEPENDS.kdelibs+=	kdelibs>=3.3.0
BUILDLINK_DEPENDS.taglib+=	taglib>=1.4

.include "../../audio/arts/buildlink3.mk"
.include "../../audio/libvisual/buildlink3.mk"
.include "../../audio/taglib/buildlink3.mk"
.include "../../audio/tunepimp/buildlink3.mk"
.include "../../audio/xmms/buildlink3.mk"
.include "../../meta-pkgs/kde3/kde3.mk"
.include "../../mk/ossaudio.buildlink3.mk"
.include "../../multimedia/gst-plugins/buildlink3.mk"
.include "../../multimedia/gstreamer/buildlink3.mk"
.include "../../multimedia/kdemultimedia3/buildlink3.mk"
.include "../../multimedia/xine-lib/buildlink3.mk"
.include "../../x11/kdebase3/buildlink3.mk"
.include "../../x11/kdelibs3/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"