[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / audio / adplug

File: [cvs.NetBSD.org] / pkgsrc / audio / adplug / Makefile (download)

Revision 1.8, Tue Dec 11 09:50:44 2018 UTC (5 years, 4 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2019Q2-base, pkgsrc-2019Q2, pkgsrc-2019Q1-base, pkgsrc-2019Q1, pkgsrc-2018Q4-base, pkgsrc-2018Q4
Changes since 1.7: +5 -6 lines

adplug: update to 2.3.1.

Changes for version 2.3.1:
--------------------------
- Fixed unconditional inclusion of "sys/io.h" on Linux
- Autotools improvement
  - Non-recursive Automake, improved parallelizability
  - Compatibility fixes for FreeBSD's pmake and OpenBSD's make
  - Out-of-source building

Changes for version 2.3:
-------------------------
- Bug fixes:
  - CMF: Fix uninitialised variable use (thanks binarymaster)
  - CMF: Handle invalid offsets without crashing
  - ROL: Prevent access beyond end of vector
  - MSC: Fix use of uninitialised variable
  - HSC: Handle out of range patterns more gracefully
  - MID: Fix for issue #2 - out of range array read
  - LDS: Use the tempo stored inside the Loudness-File instead of simply returning 70Hz
  - RIX: Fix several replay bugs (thanks to Palxex)
  - RIX: Big-endian fix by Wei Mingzhi
  - XAD: Tempo fix
  - Various other out of bounds array fixes, timing fixes, etc.
- New formats:
  - BMF: Easy AdLib 1.0
  - CMF: SoundFX Macs Opera
  - GOT: God of Thunder
  - HSQ/SQX/SDB/AGD/HA2: Herbulot AdLib System (HERAD)
  - MUS/IMS/MDI: AdLib Visual Composer ROL derivatives
  - SOP: sopepos' Note Player
  - VGM: Video Game Music
- Allow compilation on platforms that don't support real OPL hardware access
- Add support for compiling on Appveyor and publishing a NuGet package
- Add Visual Studio 2015 projects
- Add support for Travis CI builds
- Add new CRC16 and CRC32 tests
- Addition of WoodyOPL from DOSBox SVN (thanks to NY00123)
- Addition of NukedOPL (thanks to loki666 and nukeykt)
- Move from SourceForge to GitHub
- DRO player refactored (thanks to Laurence Myers and William Yates)
- Add (mono) OPL3 support to the surround/harmonic-effect OPL
- Fix occasional random noise in right channel when using surround OPL and Satoh synth
- Add display for ROL comment and instrument names
- Improve support for different Westwood ADL format versions
- Improve CMF transpose support (per-channel now)
- Autotools build environment updated

Changes for version 2.2.1:
--------------------------
- Bug fixes:
  - CMF: Fix crash on v1.0 files
  - DRO: Correct playback of early v0.1 files

Changes for version 2.2:
------------------------
- New format support:
  - JBM: JBM Adlib Music Format
  - CMF: New player (more accurate) for Creative Music Format
  - DRO: DOSBox Raw OPL v2.0 support
- Fixed current subsong rewind in D00 player.
- Added test case for ADL file format.
- Fixed replay bug in DRO player (thanks to Adam Nielsen).
- New surround/harmonic synth effect (sounds really nice!)

# $NetBSD: Makefile,v 1.8 2018/12/11 09:50:44 wiz Exp $

DISTNAME=	adplug-2.3.1
CATEGORIES=	audio devel
MASTER_SITES=	${MASTER_SITE_GITHUB:=adplug/}
GITHUB_RELEASE=	${PKGNAME_NOREV}
EXTRACT_SUFX=	.tar.bz2

MAINTAINER=	jfranz@bsdprojects.net
HOMEPAGE=	https://github.com/adplug/adplug/
COMMENT=	AdLib emulator library supporting many formats
LICENSE=	gnu-lgpl-v2.1

GNU_CONFIGURE=	yes
USE_LIBTOOL=	yes
USE_TOOLS+=	pkg-config
USE_LANGUAGES=	c c++
INFO_FILES=	yes

PKGCONFIG_OVERRIDE+=	adplug.pc.in

.include "../../devel/libbinio/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"