[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / audio / abcde

File: [cvs.NetBSD.org] / pkgsrc / audio / abcde / Makefile (download)

Revision 1.55, Wed Jul 1 09:28:25 2015 UTC (8 years, 9 months ago) by wiz
Branch: MAIN
Changes since 1.54: +2 -3 lines

Update to 2.7:

Changes in 2.7
* Rewrite of the mungefilename function.
* Support added for downloading album art.
* Support added for ripping with libcdio (cd-paranoia).
* Some error checking and a small help file added to abcde-musicbrainz-tool.
* Substantial renovations of m4a encoding with a choice now between encoding
  with faac, NeroAacEnc and fdkaac.
* Fixes to USEPIPES with the addition of several new encoders and rippers.
  Details on USEPIPES now available in the abcde FAQ doc.
* Support added for encoding with Monkey's Audio (ape), tagging is with
  Robert Muth's apetag.
* Support added for encoding with WavPack.
* mp3 tagging renovated with version sniffing differentiating between eyeD3
  versions. Tagging formalised with options now for id3, id3v2 and eyeD3.
* Many, many bug fixes. See the changelog for more details.

# $NetBSD: Makefile,v 1.55 2015/07/01 09:28:25 wiz Exp $

DISTNAME=	abcde-2.7
CATEGORIES=	audio
MASTER_SITES=	http://abcde.einval.com/download/

MAINTAINER=	sekiya@NetBSD.org
HOMEPAGE=	http://abcde.einval.com/
COMMENT=	Command-line utility to rip and encode an audio CD

DEPENDS+=	cd-discid>=0.7:../../audio/cd-discid
DEPENDS+=	eyeD3-[0-9]*:../../audio/eyeD3
DEPENDS+=	id3-[0-9]*:../../audio/id3
DEPENDS+=	cdparanoia>=3.0.9.7:../../audio/cdparanoia
DEPENDS+=	mkcue>=2.1:../../misc/mkcue

NO_BUILD=	yes
WRKSRC=		${WRKDIR}/${PKGNAME_NOREV}

USE_TOOLS+=	bash:run ftp:run gsed:run
REPLACE_BASH=	abcde cddb-tool
REPLACE_PERL+=	abcde-musicbrainz-tool

# even with all these installed, abcde-musicbrainz-tool does not work
#USE_TOOLS=	perl:run
#DEPENDS+=	p5-MusicBrainz-DiscID-[0-9]*:../../audio/p5-MusicBrainz-DiscID
#DEPENDS+=	p5-WebService-MusicBrainz-[0-9]*:../../net/p5-WebService-MusicBrainz

EGDIR=		${PREFIX}/share/examples/abcde

MESSAGE_SUBST+=	EGDIR=${EGDIR}
MESSAGE_SUBST+=	PKG_SYSCONFDIR=${PKG_SYSCONFDIR}

INSTALLATION_DIRS=	bin ${PKGMANDIR}/man1

SUBST_CLASSES+=		abcde
SUBST_STAGE.abcde=	pre-configure
SUBST_MESSAGE.abcde=	Adjusting the directory for configuration files
SUBST_FILES.abcde=	abcde abcde.1
SUBST_SED.abcde=	-e "s,/etc/,${PKG_SYSCONFDIR}/,g"

SUBST_CLASSES+=		gsed
SUBST_STAGE.gsed=	pre-configure
SUBST_MESSAGE.gsed=	Adjusting gsed path
SUBST_FILES.gsed=	abcde
SUBST_SED.gsed=		-e "s, sed , ${TOOLS_PATH.gsed} ,g"

do-install:
	${INSTALL_SCRIPT} ${WRKSRC}/abcde ${DESTDIR}${PREFIX}/bin
	${INSTALL_SCRIPT} ${WRKSRC}/cddb-tool ${DESTDIR}${PREFIX}/bin
#	${INSTALL_SCRIPT} ${WRKSRC}/abcde-musicbrainz-tool ${DESTDIR}${PREFIX}/bin
	${INSTALL_DATA_DIR} ${DESTDIR}${EGDIR}
	${INSTALL_DATA} ${WRKSRC}/abcde.conf ${DESTDIR}${EGDIR}
	${INSTALL_MAN} ${WRKSRC}/abcde.1 \
		${DESTDIR}${PREFIX}/${PKGMANDIR}/man1
	${INSTALL_MAN} ${WRKSRC}/cddb-tool.1 \
		${DESTDIR}${PREFIX}/${PKGMANDIR}/man1

.include "../../mk/bsd.pkg.mk"