File:  [cvs.NetBSD.org] / pkgsrc / archivers / py-zstandard / Makefile
Revision 1.31: download - view: text, annotated - select for diffs
Mon Nov 11 07:27:51 2024 UTC (5 months, 1 week ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2024Q4-base, pkgsrc-2024Q4, HEAD
py-*: remove unused tool dependency

py-setuptools includes the py-wheel functionality nowadays

# $NetBSD: Makefile,v 1.31 2024/11/11 07:27:51 wiz Exp $

DISTNAME=	zstandard-0.23.0
PKGNAME=	${PYPKGPREFIX}-${DISTNAME}
CATEGORIES=	archivers python
MASTER_SITES=	${MASTER_SITE_PYPI:=z/zstandard/}

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	https://github.com/indygreg/python-zstandard
COMMENT=	Zstandard bindings for Python
LICENSE=	modified-bsd

TOOL_DEPENDS+=	${PYPKGPREFIX}-setuptools>=0:../../devel/py-setuptools
DEPENDS+=	${PYPKGPREFIX}-cffi>=1.11:../../devel/py-cffi
TEST_DEPENDS+=	${PYPKGPREFIX}-hypothesis-[0-9]*:../../devel/py-hypothesis

PYTHON_VERSIONS_INCOMPATIBLE=	27

BUILDLINK_API_DEPENDS.zstd+=	zstd>=1.5.6

# https://github.com/indygreg/python-zstandard/issues/220
post-extract:
	${RM} ${WRKSRC}/zstd/zstd.h
	${LN} -s ${BUILDLINK_DIR}/include/zstd.h ${WRKSRC}/zstd/zstd.h

.include "../../archivers/zstd/buildlink3.mk"
.include "../../lang/python/wheel.mk"
.include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>