The NetBSD Project

CVS log for pkgsrc/archivers/py-libarchive-c/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / archivers / py-libarchive-c

Request diff between arbitrary revisions


Keyword substitution: kv
Default branch: MAIN


Revision 1.17: download - view: text, markup, annotated - select for diffs
Mon Nov 11 07:27:51 2024 UTC (3 months, 1 week ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2024Q4-base, pkgsrc-2024Q4, HEAD
Diff to: previous 1.16: preferred, colored
Changes since revision 1.16: +1 -2 lines
py-*: remove unused tool dependency

py-setuptools includes the py-wheel functionality nowadays

Revision 1.16: download - view: text, markup, annotated - select for diffs
Wed Mar 6 18:53:34 2024 UTC (11 months, 1 week ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2024Q3-base, pkgsrc-2024Q3, pkgsrc-2024Q2-base, pkgsrc-2024Q2, pkgsrc-2024Q1-base, pkgsrc-2024Q1
Diff to: previous 1.15: preferred, colored
Changes since revision 1.15: +2 -2 lines
py-libarchive-c: updated to 5.1

5.1

Fix the format_name property and move it from the ArchiveEntry class to the ArchiveRead class

Revision 1.15: download - view: text, markup, annotated - select for diffs
Thu Jan 18 18:11:39 2024 UTC (13 months ago) by adam
Branches: MAIN
Diff to: previous 1.14: preferred, colored
Changes since revision 1.14: +8 -4 lines
py-libarchive-c: updated to 5.0

5.0

Changes to the library:

It is now possible to specify a codec for archive entry metadata (pathname, linkpath, uname and gname)
BREAKING: If you use the archive_read_class and archive_write_class arguments, the classes you provide will receive a codec name as a second positional argument.
The timestamp_nsec arguments of the legacy ArchiveEntry.set_{a,c,m}time methods are now optional

Changes to the tests and packaging:

Removed obsolete dependencies (mock and six) from tox.ini
Always use UTF-8 when reading the PKG-INFO and README.rst files
Replaced pytest-xdist with pytest-forked in tox.ini
Dropped testing with Python 3.7. Added 3.10 and 3.11


4.0

BREAKING & SECURITY: The archive extraction functions now pass 3 security flags (SECURE_NODOTDOT, SECURE_NOABSOLUTEPATHS and SECURE_SYMLINKS) to libarchive by default, unless the current directory is the root.
BREAKING: The ArchiveEntry properties atime, mtime, ctime, birthtime and size now have the value None instead of 0 when they're unset.
BREAKING: The ArchiveEntry.pathname property now attempts to decode bytes using UTF-8. This breaks reading archives that contain file names which look like UTF-8 but aren't, if such a thing exists. Proper support of encodings will probably be added in the next version.
Multiple entries from the same archive can now be kept in memory, however only the current entry's content can be read.
The filetype, linkpath, size, mode, redvmajor, redvminor, uid and gid attributes of an archive entry can now be modified.
The four time properties of archive entries now have setters, so for example entry.set_mtime(0, 0) can be replaced by entry.mtime = 0.
Archive entries have 4 new properties: perm, rdev, uname and gname.
When adding files to an archive, a destination path can now be specified.
The ArchiveRead class now has a bytes_read property.
The ArchiveWrite class now has a bytes_written property.
Python 3.6 is no longer tested.
The documentation has been improved.

Revision 1.14: download - view: text, markup, annotated - select for diffs
Tue Jan 4 20:52:31 2022 UTC (3 years, 1 month ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2023Q4-base, pkgsrc-2023Q4, pkgsrc-2023Q3-base, pkgsrc-2023Q3, pkgsrc-2023Q2-base, pkgsrc-2023Q2, pkgsrc-2023Q1-base, pkgsrc-2023Q1, pkgsrc-2022Q4-base, pkgsrc-2022Q4, pkgsrc-2022Q3-base, pkgsrc-2022Q3, pkgsrc-2022Q2-base, pkgsrc-2022Q2, pkgsrc-2022Q1-base, pkgsrc-2022Q1
Diff to: previous 1.13: preferred, colored
Changes since revision 1.13: +2 -1 lines
*: bump PKGREVISION for egg.mk users

They now have a tool dependency on py-setuptools instead of a DEPENDS

Revision 1.13: download - view: text, markup, annotated - select for diffs
Wed Dec 11 13:46:46 2019 UTC (5 years, 2 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2021Q4-base, pkgsrc-2021Q4, pkgsrc-2021Q3-base, pkgsrc-2021Q3, pkgsrc-2021Q2-base, pkgsrc-2021Q2, pkgsrc-2021Q1-base, pkgsrc-2021Q1, pkgsrc-2020Q4-base, pkgsrc-2020Q4, pkgsrc-2020Q3-base, pkgsrc-2020Q3, pkgsrc-2020Q2-base, pkgsrc-2020Q2, pkgsrc-2020Q1-base, pkgsrc-2020Q1, pkgsrc-2019Q4-base, pkgsrc-2019Q4
Diff to: previous 1.12: preferred, colored
Changes since revision 1.12: +3 -3 lines
py-libarchive-c: updated to 2.9

2.9:
Changes to the library:
optimized the ArchiveEntry class
added support for the zstd format
fixed the top-level __all__ list (7b97d8b)
updated the code to support Python 3.8
improved the add_file_from_memory method
lowered the level of log messages from warning to info

Tests:
dropped testing with Python 3.4, added 3.7 and 3.8
fixed unicode handling in entry tests

Revision 1.12: download - view: text, markup, annotated - select for diffs
Fri Jun 15 08:08:18 2018 UTC (6 years, 8 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2019Q3-base, pkgsrc-2019Q3, pkgsrc-2019Q2-base, pkgsrc-2019Q2, pkgsrc-2019Q1-base, pkgsrc-2019Q1, pkgsrc-2018Q4-base, pkgsrc-2018Q4, pkgsrc-2018Q3-base, pkgsrc-2018Q3, pkgsrc-2018Q2-base, pkgsrc-2018Q2
Diff to: previous 1.11: preferred, colored
Changes since revision 1.11: +2 -2 lines
py-libarchive-c: updated to 2.8

Changes 2.8:
add support for setting atime, ctime, mtime and birthtime
tell libarchive when writing an archive is aborted due to an exception
add support for getting uid and gid
add support for high resolution timestamps
add two new archive readers: stream_reader and custom_reader
add missing archive extraction flags
add the lz4 and warc formats
add support for write options and uid/gid lookup

Revision 1.11: download - view: text, markup, annotated - select for diffs
Mon Oct 16 07:42:02 2017 UTC (7 years, 4 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2018Q1-base, pkgsrc-2018Q1, pkgsrc-2017Q4-base, pkgsrc-2017Q4
Diff to: previous 1.10: preferred, colored
Changes since revision 1.10: +5 -4 lines
py-libarchive-c: update to 2.7

2.7
only read regular files
add support for atime and ctime

Revision 1.10: download - view: text, markup, annotated - select for diffs
Tue Aug 15 21:04:09 2017 UTC (7 years, 6 months ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2017Q3-base, pkgsrc-2017Q3
Diff to: previous 1.9: preferred, colored
Changes since revision 1.9: +2 -9 lines
Remove hack for finding libarchive that is not correct any longer.
Bump PKGREVISION.

Revision 1.9: download - view: text, markup, annotated - select for diffs
Mon May 29 11:09:45 2017 UTC (7 years, 8 months ago) by jperkin
Branches: MAIN
CVS tags: pkgsrc-2017Q2-base, pkgsrc-2017Q2
Diff to: previous 1.8: preferred, colored
Changes since revision 1.8: +2 -2 lines
Recursive revision bump for archivers/libarchive.

Revision 1.8: download - view: text, markup, annotated - select for diffs
Fri Jul 1 17:55:23 2016 UTC (8 years, 7 months ago) by jperkin
Branches: MAIN
CVS tags: pkgsrc-2017Q1-base, pkgsrc-2017Q1, pkgsrc-2016Q4-base, pkgsrc-2016Q4, pkgsrc-2016Q3-base, pkgsrc-2016Q3
Diff to: previous 1.7: preferred, colored
Changes since revision 1.7: +2 -1 lines
The recent libarchive update changed the library major.  Increase the
ABI depends and perform a PKGREVISION bump for dependents.

Noticed by OSX binary package users.

Revision 1.7: download - view: text, markup, annotated - select for diffs
Wed Jun 8 17:49:19 2016 UTC (8 years, 8 months ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2016Q2-base, pkgsrc-2016Q2
Diff to: previous 1.6: preferred, colored
Changes since revision 1.6: +2 -2 lines
Switch to MASTER_SITE_PYPI.

Revision 1.6: download - view: text, markup, annotated - select for diffs
Sun May 29 18:49:54 2016 UTC (8 years, 8 months ago) by wiz
Branches: MAIN
Diff to: previous 1.5: preferred, colored
Changes since revision 1.5: +3 -8 lines
Updated py-libarchive-c to 2.4.

This is a fix release that doesn't change the library code. Details:

    fixed file permissions in PyPI archives (#30)
    fixed Travis CI builds (#32)

Revision 1.5: download - view: text, markup, annotated - select for diffs
Sun May 22 13:32:18 2016 UTC (8 years, 8 months ago) by wiz
Branches: MAIN
Diff to: previous 1.4: preferred, colored
Changes since revision 1.4: +4 -4 lines
Update py-libarchive-c to 2.3:

License changed to cc0.

Add link to upstream bug report about permissions problem.

Revision 1.4: download - view: text, markup, annotated - select for diffs
Sun May 22 13:15:43 2016 UTC (8 years, 8 months ago) by wiz
Branches: MAIN
Diff to: previous 1.3: preferred, colored
Changes since revision 1.3: +5 -1 lines
Revert previous, permissions fixup is still needed here.

Revision 1.3: download - view: text, markup, annotated - select for diffs
Sat May 21 05:28:59 2016 UTC (8 years, 9 months ago) by richard
Branches: MAIN
Diff to: previous 1.2: preferred, colored
Changes since revision 1.2: +1 -5 lines
post-install chmod no longer necessary

Revision 1.2: download - view: text, markup, annotated - select for diffs
Mon Dec 7 09:18:30 2015 UTC (9 years, 2 months ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2016Q1-base, pkgsrc-2016Q1, pkgsrc-2015Q4-base, pkgsrc-2015Q4
Diff to: previous 1.1: preferred, colored
Changes since revision 1.1: +6 -1 lines
Fix permissions of meta files. Bump PKGREVISION.

Revision 1.1: download - view: text, markup, annotated - select for diffs
Wed Dec 2 15:14:05 2015 UTC (9 years, 2 months ago) by wiz
Branches: MAIN
Import py-libarchive-c-2.2 as archivers/py-libarchive-c.

A Python interface to libarchive. It uses the standard ctypes module
to dynamically load and access the C library.

Diff request

This form allows you to request diffs between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.

Log view options

CVSweb <webmaster@jp.NetBSD.org>