[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / archivers / p5-Compress-Bzip2

File: [cvs.NetBSD.org] / pkgsrc / archivers / p5-Compress-Bzip2 / Makefile (download)

Revision 1.19, Fri Apr 19 16:30:46 2013 UTC (10 years, 11 months ago) by hiramatsu
Branch: MAIN
Changes since 1.18: +3 -4 lines

Update p5-Compress-Bzip2 to 2.15.

Changes from previous:
----------------------
2.10 2013-03-25 rurban
   - updated bzlib-src from 1.0.2 to 1.0.6
   - [cpan #82308] make breaks on 5.17.7 by schubiger
   - [cpan #21961] update ppport.h
   - [cpan #25002] memBzip() ignores level
     keep using default 6, but honor optional level argument
   - use -std=c89 on gcc compat compilers
   - fix -Wimplicit-int warning for show_bzversion main()
   - fix a couple if dangling else corner cases
     format string errors, and unused variables.
   - [cpan #82576] fix pod formatting errors
   - [cpan #48128] support memBunzip BZh header w/o extra size prefix
     and grow dest buf dynamically. Tests in t/040-memory.t
   - [cpan #40741] fix bzreadline blocked on the broken bz2 files
   - [cpan #84223] fix ignored bzinflateInit args
   - [cpan #48124] Multiple issues with bzinflate
     support PV ref as bzinflate() buffer arg as documented.
     support status checks in chunked bzinflate() calls. t/060-inflate.t
   - [cpan #49618] fix for win32 nmake + gcc
   - fix t/041-error.t bzopen does not work with filehandles with 5.6,
     global destruction of IO::Handle mixed up with a socket
   - [cpan #36246] compress 0-byte srcfiles correctly. by Jeffrey Ratcliffe.
     fixes debian bug 464205
   - [cpan #28366] added testcase for double free or corruption on 32 bit, threaded
     but could not repro it.

2.11 2013-04-01 rurban
   - [cpan #84239] Updated FSF address
   - [cpan #68572] Workaround EUMM bug #84345 missing -R

2.12 2013-04-01 rurban
   - Fixed META.yml, added META records and SIGN, LICENSE, repository to Makefile.PL,
     META.yml is now autogenerated
   - added META and POD tests

2.13 2013-04-01 rurban
   - Fixed POD coverage

2.14 2013-04-05 rurban
   - Fixed solaris gcc issue [cpan #84432] by removing -std=c89

2.15 2013-04-05 rurban
   - Silence show_bzversion warnings with make test in t/lib.pl when -lbz2 is unusable.
     ParseConfig is duplicated and not needed in t/lib.pl, but I'll leave it there.

# $NetBSD: Makefile,v 1.19 2013/04/19 16:30:46 hiramatsu Exp $

DISTNAME=	Compress-Bzip2-2.15
PKGNAME=	p5-${DISTNAME}
CATEGORIES=	archivers perl5
MASTER_SITES=	${MASTER_SITE_PERL_CPAN:=../by-authors/id/R/RU/RURBAN/}

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	http://search.cpan.org/dist/Compress-Bzip2/
COMMENT=	Perl5 interface to bzip2 compression library
LICENSE=	gnu-gpl-v2

PERL5_PACKLIST=		auto/Compress/Bzip2/.packlist

.include "../../archivers/bzip2/buildlink3.mk"
.include "../../lang/perl5/module.mk"
.include "../../mk/bsd.pkg.mk"