[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / archivers / ocaml-zip

File: [cvs.NetBSD.org] / pkgsrc / archivers / ocaml-zip / Makefile (download)

Revision 1.1.1.1 (vendor branch), Tue Sep 2 11:45:32 2008 UTC (15 years, 7 months ago) by obache
Branch: TNF
CVS Tags: pkgsrc-base, pkgsrc-2009Q4-base, pkgsrc-2009Q4, pkgsrc-2009Q3-base, pkgsrc-2009Q3, pkgsrc-2009Q2-base, pkgsrc-2009Q2, pkgsrc-2009Q1-base, pkgsrc-2009Q1, pkgsrc-2008Q4-base, pkgsrc-2008Q4, pkgsrc-2008Q3-base, pkgsrc-2008Q3, cube-native-xorg-base, cube-native-xorg
Changes since 1.1: +0 -0 lines

Import ocaml-zip-1.03 as archivers/ocaml-zip.
Packaged by Jaap Boender and provided by PR 39113.

This Objective Caml library provides easy access to compressed files in ZIP
and GZIP format, as well as to Java JAR files.  It provides functions
for reading from and writing to compressed files in these formats.

# $NetBSD: Makefile,v 1.1.1.1 2008/09/02 11:45:32 obache Exp $
#

DISTNAME=	camlzip-${VERSION}
PKGNAME=	ocaml-zip-${VERSION}
VERSION=	1.03
CATEGORIES=	archivers
MASTER_SITES=	http://caml.inria.fr/distrib/bazar-ocaml/

MAINTAINER=	jaapb@kerguelen.org
HOMEPAGE=	http://cristal.inria.fr/~xleroy/software.html
COMMENT=	OCaml library to manipulate ZIP/GZIP/JAR archives

DEPENDS+=	ocaml-findlib-[0-9]*:../../devel/ocaml-findlib

BUILD_TARGET=	all

.if (${MACHINE_ARCH} == "i386") || (${MACHINE_ARCH} == "powerpc") || \
    (${MACHINE_ARCH} == "sparc") || (${MACHINE_ARCH} == "x86_64")
BUILD_TARGET+=	allopt
PLIST_SRC+=	PLIST.opt
.endif

PLIST_SRC+=	PLIST

post-extract:
	${CP} ${FILESDIR}/META ${WRKSRC}/META

.include "../../lang/ocaml/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"